Type in the full discussion title or a part of it.
Discussion Title Created date
USART vs. SPI
Is there example code lying around showing full-duplex SPI? The code I've been able to find show data going only from master to slave. Can an AVR with its USART in MSPI mode...
Tuesday, 18 December 2007 - 22:46
avrdude doesn't like my atMega168 anymore
I have a board with 8 atMega168s. I unprogrammed the DIV8 fuse bit on seven of them with software in the others. Forgetting about the eighth, I put coordinated blinkin lights code...
Monday, 17 December 2007 - 00:13
avrdude vs a single byte hex file
I've been trying to get avrdude to write a single byte, 0xFF, to eeprom address 0x30, so far to no avail. Here are the results of my debugging efforts: The command avrdude -n -p...
Thursday, 25 October 2007 - 23:01
AVRISPmkII's and the hardware wizard
avrdude has been telling me to double check my connections a lot lately. After 3 or 4 unsuccessful attempts, I start unplugging and replugging stuff. Eventually it works. Usually...
Sunday, 14 October 2007 - 23:18
dead canaries
The code described here is for debugging. It should not be mistaken for anything that I suspect of doing anything else useful. One version contains a ".bootloader" section...
Tuesday, 11 September 2007 - 23:26
How do I find "caller" of ISR?
For some reason, my ATmega168's keep ending up in the ISR for external interrupt 0. When I display EIMSK, it's zero, so how did I get an interrupt? That I might have called it by...
Thursday, 30 August 2007 - 01:14
overlapping sections
I used BOOTLOADER_SECTION to put some functions in the bootloader section. I tried to locate the .bootloader section with -Wl,--section-start=.bootloader=3800 , but I got the...
Thursday, 16 August 2007 - 22:18
getting usb working again
I'm using a new computer, so I've been installing WINAVR and AVR Studio. The end of the story and the reason for the post is AVR Studio won't connect to the JTAGICE mkII with USB...
Tuesday, 31 July 2007 - 22:46
How do I use an AVRISP mkII?
The AVRISP mkII is plugged into a USB port on my PC and into the ISP pins of my board. The little green light is on and steady. AVR Studio keeps telling me "connect failed". I...
Saturday, 21 July 2007 - 19:17
how do I use avrdude with JTAGICEmkII on Windows?
I'm using a JTAGICEmkII through AVR Studio on WIndows XP. Sometimes I would prefer the command line, so I tried avrdude, however:Quote:$ avrdude -p ATmega168 -c jtagmkII -U flash:...
Friday, 20 July 2007 - 21:48
How do I program SRAM?
Is there a way to program SRAM in a manner similar to the way flash and EEPROM are programmed by ISP? Debugwire through AVR Studio and a JTAGICE mkII almost does what I want, but...
Thursday, 12 July 2007 - 21:49
How do I get my library source in lss file
How do I get my library source in my lss file? The source (C) for my library is in a different directory from that of the main program. I'm only getting source for the main...
Friday, 29 June 2007 - 20:28

Pages