Post Created date
Code Generation Error in WinAVR-20100110
Entered as bug 45099 on bugzilla as requested. Thanks jrseattlle
Wednesday, 28 July 2010 - 06:20
Code Generation Error in WinAVR-20100110
Thanks everyone for the response. It's now clear that r10 is used as an argument to the __muldi3 library function. That leaves me with 2 questions: 1. Why is r10 not saved in the...
Tuesday, 27 July 2010 - 19:00
Code Generation Error in WinAVR-20100110
The attached text file WinAvrBug.txt is not readible because of strange formatting by this site. I'm attaching the file as a zip file. Hopefully that works. jrseattle
Tuesday, 27 July 2010 - 06:18
A Nice AvrDude GUI
Thanks 12oclocker. Two questions/requests: 1. why only COM1..COM3? When using a Virtual Serial Port (USB-Serial conversion), the COM ports are frequently set to something above...
Monday, 19 July 2010 - 03:59
Atmega and driver for MGG2432 LCD
Hi, The C version of the LCD has a (raw) interface similar to the Optrex DMF50840 LCD. It is possible using a 40-pin AVR to interface such an LCD, running at full speed. See my...
Monday, 19 July 2010 - 03:26
Linker error: warning: internal error: out of range error
OK, I went looking some more and found out that it is "User Error", though the linker can definitely do a better job at reporting this. The good news is that I learned something...
Thursday, 25 March 2010 - 19:09
Linker error: warning: internal error: out of range error
Thanks for the replies. Yes, I did search for the suggested string, here and other places, but nothing relevant to my case showed up. However, the discussions on this issue go...
Thursday, 25 March 2010 - 03:14
Arduino ATMega328P JTAGICE MKII
Using "DebugWire" on a newer Arduino board (diecimila, duemilanove) with an Atmega168 or Atmega328p is impossible. These boards have a capacitor connector to the reset line, which...
Friday, 4 December 2009 - 05:34
ISP trouble after migrating to M328P
You're confusing matters by suddenly talking about a M324P, while you started out with a M328P!!!
Sunday, 15 November 2009 - 17:42
Programming Atmega328p in parallel mode
It's been a year since I posted this problem, time for an update. Unfortunately, the problem has not been fixed. I'm using AVR Studion 4.18, build 682, and the Atmega328p cannot...
Wednesday, 11 November 2009 - 04:34
avr-as vs avrasm2 lpm/sts gotcha
Thanks all for your answers; learned a couple of new things (proper syntax and 6-bit range limitation for ADIW). Sorry for using an old thread but the topic was very relevant....
Tuesday, 3 November 2009 - 19:20
avr-as vs avrasm2 lpm/sts gotcha
sternst: Your answer does not work; it results in these errors: ../dmf50840.S: Assembler messages: ../dmf50840.S:434: Error: can't resolve `0' {*ABS* section} - `Font8x8' {.text...
Tuesday, 3 November 2009 - 19:13

Pages