Post Created date
Please Help, Some lines of code are not compiled...!!!!!!!
First, thank you all for your kindly reply's, and your effort to make me learn, I've learned so much from all of you. Quote:Aren't [at least] one of you gurus going to tell OP...
Saturday, 13 February 2010 - 08:13
Please Help, Some lines of code are not compiled...!!!!!!!
Any reply??
Friday, 12 February 2010 - 09:11
Please Help, Some lines of code are not compiled...!!!!!!!
Hi Cliff Really I appreciate your effort to help me. many thanks. I'm not familiar with assembly language, so, could u please tell me where the function Delay() calls the function...
Wednesday, 10 February 2010 - 18:24
Please Help, Some lines of code are not compiled...!!!!!!!
Quote:Show us the disassembly that Studio gives you. As it uses word not byte addressing lets see what it's showing you between 0x54D to 0x55A @0000054D: CLS 86: { +...
Wednesday, 10 February 2010 - 17:48
Please Help, Some lines of code are not compiled...!!!!!!!
Hi there I think it is not Proteus Problem, Because AVR studio simulator make the same behavior, when I run the AVR-studio simulator, It is not accept to make a break point at the...
Wednesday, 10 February 2010 - 17:19
Please Help, Some lines of code are not compiled...!!!!!!!
Quote:What is this development system/debugger/disassembler anyway? (it seems a bit crap if you don't mind me saying) Quote:Which debugger are you using? I'm using Proteus, .elf...
Wednesday, 10 February 2010 - 14:41
Please Help, Some lines of code are not compiled...!!!!!!!
Here is the disassemble of the 2 functions: Delay(), and CLS();
Wednesday, 10 February 2010 - 14:19
Please Help, Some lines of code are not compiled...!!!!!!!
Dear all Many thanks to all of u, I've changed the code to avoid using delay loops look at the Pictures,The Delay() function uses the _delay_ms() function, and because i can not...
Wednesday, 10 February 2010 - 13:49
Please Help, Some lines of code are not compiled...!!!!!!!
dear all.many thanks to all of u, now i understood the proplem of delay loops. But what about the line in which the variable is incremented?? And there is another line in which i...
Tuesday, 9 February 2010 - 17:11
Please Help, Some lines of code are not compiled...!!!!!!!
david.prentice wrote:You do not say which lines are not compiled. My crystal ball says the 'delay(0x5FFF)' does nothing. The compiler has decided that the code does not do...
Tuesday, 9 February 2010 - 13:58
Please Help, Some lines of code are not compiled...!!!!!!!
The symptoms: * the functions are not called; * Also, there are simple lines like y = 0, or z++ are not compiled too expectations: Really I don't know.
Tuesday, 9 February 2010 - 13:50
Running AVRStudio on Linux
Thanks Aor_Dreamer for your great HOWTO. it is very helpful but what about WINAVR??? Did you install it?? and if yes, how?? I'm using FC8, and hope everything will go smoothly as...
Wednesday, 18 June 2008 - 14:25

Pages