Type in the full discussion title or a part of it.
Discussion Title Created date
UC3C RTS issue
I thought only the UC3A had RTS issues (seemingly still undocumented from what I see in the datasheets) but it seems that the UC3C has it's own. Using a UC3C1512C, when setting...
Thursday, 13 June 2013 - 01:08
Any plans on when AS5 will support AT90CANxx?
I'd like to try it out but since I'm using many AT90CAN's in my projects, I can't debug them with AS5.
Saturday, 2 April 2011 - 15:25
Stack corruption with AVR toolchain
With the beta AVR toolchain 3.0.0.207, the prologue for functions using a frame has changed and is now causing stack corruption when an interrupt fires. Take for example a...
Thursday, 12 August 2010 - 17:05
XMEGA JTAG problem
We have recently started converting some of our modules to the XMEGA series of micros. Unfortunately it seems that we cannot connect to them via the JTAG port. When we received...
Tuesday, 17 November 2009 - 23:53
No flashing in 4.16?
It appears there is a new bug in the hex flashing in AStudio 4.16 If I try to flash a bootloader into a blank micro, the programming process actually skips flashing, but the...
Saturday, 28 February 2009 - 15:45
WinAVR20080610 Bugs
I've been gone a while but now I'm back and writing code again. I've started running the latest 20080610 version and noticed two things: The BSS bug is still there. This happens...
Saturday, 4 October 2008 - 04:05
BSS in Flash?
It seems that the linker is putting the BSS section into flash...or at least is addressing it there so I can't effectively use the space for code. From the .lss file: Sections:...
Tuesday, 4 March 2008 - 00:58
Skipping instructions
Hi, I believe that I have inadvertently found a way to get the AVR to skip instructions (or at least misexecute them). I have a CAN128 using digital inputs on PORTD. the...
Tuesday, 20 November 2007 - 15:42
Signedness
Just installed WinAVR20070122 and I'm getting all sorts of "warning: pointer targets in passing argument 2 of 'itoa' differ in signedness". I'm passing an unsigned array as a...
Tuesday, 13 February 2007 - 21:53
Debugging with Libraries
I've recently started putting some functions in a library to use in various applications. The unfortunate problem is that whenever I debug an application using my library, it won...
Tuesday, 13 February 2007 - 20:58