Post Created date
Atmel Studio 7.0 Beta
clawson wrote: Yup that ship sailed when Atmel abandoned AVR32 Studio (Eclipse based - potential for following "Studio"s to all be multi-OS) and sold their soul to the M$ machine...
Monday, 29 June 2015 - 12:07
Circuitmaker ...or how Altium plans to give You something for nothing
I'm generally concerned about pouring my efforts into learning, and then designing, in a tool that is either new (and therefore may be discontinued), freemium (where the pricing...
Friday, 26 June 2015 - 06:32
ATmega328 code compiles, uploads, does not execute?
Perhaps I'm not looking in the right place.   My very first call of the main() is to a routine that configures the UART: void UART_Init(uint16_t baudRate) { uint16_t...
Thursday, 25 June 2015 - 14:16
ATmega328 code compiles, uploads, does not execute?
Which still leaves me scratching my head... maybe I just need to move on with life and put it into the category of the inexplicable.
Thursday, 25 June 2015 - 12:33
ATmega328 code compiles, uploads, does not execute?
clawson wrote: So I figured that maybe there was some kind of memory issue  What did the avr-size report during the build say? What was the combined size of .data and .bss...
Thursday, 25 June 2015 - 11:38
ATmega328 code compiles, uploads, does not execute?
Thanks all - appreciate the input.  Have taken the comments and suggestions and worked through them. I don't have any kind of versioning in place, so that's a good place to...
Wednesday, 24 June 2015 - 20:15
ATmega328 code compiles, uploads, does not execute?
Fair comment on not giving enough detail - suitably slapped on the wrists ;) Apologies. Line 2 of the code in the main() routine outputs a welcome message to the UART - this is...
Wednesday, 24 June 2015 - 15:57