Post Created date
Interrupts disabled after entering a sub-routine ?
sei(); ... while(1) { if(mode_Diagnostic) SendDiagnostics(); .... void SendDiagnostics(void) { struct AS5043Status testFirstAS5043, testAS5043[3]; struct...
Monday, 12 November 2012 - 20:12
Interrupts disabled after entering a sub-routine ?
Update: There seem to be lots of places where 'cli' is found in .lss file and it looks not like there is always a sei !
Monday, 12 November 2012 - 19:39
Question about SPI
I tested yesterday. 1) The SPI has to be temporarily disabled, otherwise changing the SCK-line has no effect 2) the SCK-line has to be configured as OUTPUT and with HIGH-level...
Monday, 12 November 2012 - 13:28
shift right/left memory area
Another solution could be to manually generate a clock pulse on the SCK line without reading data. But I thought it would be more convenient to read all the data in one shot, then...
Sunday, 11 November 2012 - 09:35
shift right/left memory area
The datagram of a AS5043 consists of 16 Bits data and ONE "dummy" bit until the next chips datagram is shifted out. So for 3 chips I have to read at least 51 bits. But the SPI...
Sunday, 11 November 2012 - 09:33
SPI problem - WCOL is HIGH
PB0 is officially used for SS. I do NOT use this pin for chip select.
Sunday, 30 September 2012 - 08:02
SPI problem - WCOL is HIGH
The problem is the same. it doe snot matter whether a salve is connectedc or not.
Saturday, 29 September 2012 - 19:27
SPI problem - WCOL is HIGH
the AVR is master, a port line is configured as output
Saturday, 29 September 2012 - 19:26
What's this? After installing teh last updates ....
It did not work; I am sorry. AS 6 now works as desired again. I applied the last patch again and explicitely chose run as administrator. Then it worked. Thank you
Thursday, 12 July 2012 - 20:49
What's this? After installing teh last updates ....
I definitely have restarted the machine and AS6 - same problem again. Find attached the xml-file which is described in the error message - I cannot do anything with this.
Wednesday, 11 July 2012 - 15:34
bit shifting trouble with multi-byte SPI or how to shift me
Is there a ready-to-use code for shift-operations on a memory area of 8 Bytes ? I tried a lot with uint64_t to handle the daisy-chained chips. It seems easy to read the first (or...
Saturday, 7 July 2012 - 16:44
SPI communication with AS5043
Thank you for your help. The first lab-tests with this chip are really hard to do. Not only the SPI-comm itself is tricky, but also positioning the magnet is difficult - by hand...
Wednesday, 27 June 2012 - 09:14

Pages