Post Created date
strange SPI-problem in AS6
Great! Now it works. Thank you for your help. Indeed, the MSTR bit is set by my code, but it remains LOW until SS is configured as output. If SS is not configured (which means =...
Thursday, 17 January 2013 - 19:48
Problem with net shares assigned to drive letters ...
Thank you for your answer. 1) The drive letter are accessible from the explorer ( normal net-share-icon, noc red cross, contentis browsable/visble) 2) Nevertheless, AS6 then...
Wednesday, 2 January 2013 - 09:03
UART swallows first byte while sending
This is the cod ein question ... void UARTRingbuffer_TX_CheckStart(void) { if((UART_TX_Control.QueueRunning==0)...
Sunday, 30 December 2012 - 19:55
UART swallows first byte while sending
???? Why is this superfluous ? As far as I understand, transmission is started by writing a single (the first?) byte to UDR. The you can ... - wait until TXC says the byte has...
Sunday, 30 December 2012 - 19:41
UART swallows first byte while sending
Thank you for your help. Nevertheless, I have to write the first byte into UDR to trigger the transmission. My problem was, that I first enbaled UDRIE and then with the next code...
Sunday, 30 December 2012 - 18:44
UART swallows first byte while sending
???? May be I am wrong for a long time. All my projects using an USART use the UDRE-interrupt STart of transmission: 1) enable UDRIEx to allow an interrupt to be fired 2) write...
Saturday, 29 December 2012 - 15:39
GIE disables itself - AS6
I am sorry, I don't have UART at this layout.
Tuesday, 13 November 2012 - 09:34
GIE disables itself - AS6
As I wrote before: Single-Stepping into my subroutine disables the I-Flag. For me it seems that teh I-Flag then stays disabled. Inmy case this affects CAN: Inside the subroutine...
Tuesday, 13 November 2012 - 09:33
GIE disables itself - AS6
Do you have any ideas how to correct this problem ? I spent nearly whole of the weekend, because my code sometimes reaches interrupt-service-routines and sometimes not. E.g. I...
Tuesday, 13 November 2012 - 07:16
Question about SPI
The problem is now solved for me. Of course, it is possible to simply read an additional byte, but then I have the dummy bits somewhere in the middle of the bit stream and have to...
Tuesday, 13 November 2012 - 07:04
Interrupts disabled after entering a sub-routine ?
according to the posting above, I think it has something to do with single-stepping the code. I am facing problems with sometimes reaching ISR-code, sometimes not! At the moment...
Monday, 12 November 2012 - 21:43
Interrupts disabled after entering a sub-routine ?
Okay, seems that the cli is normal, but the behaviour in AS6.1938 is not. This could explain other strange phenomen. But how can I get a perfect working AS6 ?
Monday, 12 November 2012 - 20:30

Pages