Post Created date
Debugger showing archive source
Hello clawson, Thanks for the replies. As suggested by you I did avr-strip -g for both the .o files and recreated the .a file. Now when I debug in stdio, I get a message in the...
Sunday, 10 March 2013 - 16:49
Debugger showing archive source
Hello mailtosarathy, Thanks for the reply. After seeing your reply I checked the makefile and the optimization is set to s, however Debug option was set to dwarf-2. I removed this...
Sunday, 10 March 2013 - 16:21
avr-gcc 4.7.0 for the brave
Hi, const char PROGMEM ch; works. No errors are reported. Used makefile and PN for compiling an existing project. Avr-size has thrown out error. It does not understand --mcu...
Monday, 17 September 2012 - 16:42
avr-gcc 4.7.0 for the brave
Hi, I just downloaded AVR-GCC-4.7.2. Tried to compile an existing project where I have used PROGMEM. I am getting errors!!! The earlier version compiled OK. Thanks for any...
Monday, 17 September 2012 - 12:55
No flashing in 4.16?
Hello all, I had faced the same problem. I have made myself an ISP based on Mega8 and it worked fine all along. When I tried to load boot coed into a Meag64, every time verify...
Tuesday, 5 May 2009 - 07:53
German characters on LCD
Hello, There is one way of getting your characters, though it is a bit involved. Most of the LCD controllers provide character RAM, so one needs to create a graphical image of the...
Wednesday, 16 February 2005 - 17:15
Newbie AVR-GCC example code
Hello no_idea, The problem could be because of the optimization in Makefile. Open the make file and check "opt = " line. If the line is opt = s replace 's' with '0' (zero). Now re...
Wednesday, 16 February 2005 - 16:57
timer.h seems to have vanished in the new release!!!
Dear Jorg, Thanks for a very prompt reply. But I have been using the latest WinAvr and in many of my applications I used timers and in all cases included the timer.h and never...
Wednesday, 16 February 2005 - 10:49
Help TWI interface problem
Hello, Here is the code. void TWI_start(void); unsigned char TWI_read_ack(void); unsigned char TWI_read_nack(void); void TWI_write(unsigned char); void TWI_stop(void...
Thursday, 4 November 2004 - 12:32
Help TWI interface problem
Yes I will be able to post the code and the schematic but it will be many hours before I can do that.
Wednesday, 3 November 2004 - 18:25
Help TWI interface problem
Thanks Dave for the reply. There is no problem with one chip! We even tried on a totally new board assuming that there may be some PCB track problems. But the behaviour is...
Wednesday, 3 November 2004 - 17:00
how to not init variates everytime after reset?
Thanks for a detailed reply. Yes it is possible to detect, for example a WDT reset, but how to detect a power fail reset from a cold reset? Any light ont this will be highly...
Sunday, 24 October 2004 - 13:49

Pages