Type in the full discussion title or a part of it.
Discussion Title Created date
Do GPIO pin pullup/downs only trigger when outside of an interrupt?
My initial thoughts are no and are how could this possibly be true as interrupts still have direct access to registers. However I have been seeing some interesting situations...
Tuesday, 28 July 2015 - 02:54
uint8_t indexing in 256b ring buffer. What are disadvantages to using int overflow?
I've decided to use a ring buffer (FIFO) for my SPI communications, however I am unsure if I specify that my buffer is only every going to be 256 bytes large, if using 8 bit...
Wednesday, 6 May 2015 - 00:15
Recompiling Bitcloud HAL for SPI
Hi Guys,   Following on from topics such as: https://www.avrfreaks.net/forum/u... https://www.avrfreaks.net/forum/...   I am trying to recompile HAL to disable the...
Friday, 6 February 2015 - 05:02
External makefile in Atmel Studio error
Hi Guys,   Forgive me if I have this in the wrong forum, couldn't think where to post this thread.   I downloaded bitcloud, the atmel zigbee stack and I am trying to...
Monday, 5 January 2015 - 02:46
Interrupts trigger mid procedure
Hi Gents,   I am currently using a 16 bit number that increments event millisecond via an interrupt. Whenever I want to inspect this number I disable interrupts, copy it then...
Monday, 27 October 2014 - 04:21
Stack/Heap Overrun?
Hi Guys,   I have been working with my mega644PA for a while now with a fair sized application that still has a few bugs that are very hard to find. In my main loop every...
Monday, 8 September 2014 - 04:37
Sleep Timer Restarts after a few minutes
Hi guys, I have been trying to create a basic application that goes into a sleep state during low power periods. It must use the timer during this time to increment and keep time...
Friday, 15 August 2014 - 04:40
Multiplexed GPIO Pins - Which USART Pins?
Hey Guys, Have just started looking into 32-bit uControllers after being around the 8-bits for sometime now. Previoulsy with devices like the atmega644 that I used only 1 pin for...
Monday, 17 March 2014 - 04:43
recordtype 3 in bootloader
Hi gents, I am in the process of making my own ISP and everything works fine with generic applications thus far but I am unsure how to handle a bootloader application with the...
Friday, 7 February 2014 - 02:08
Bricked Atmega168
Hey Guys, I have read over Cliff's thread...mostly and have tried to unbrick my LCD Backpack. Massive pain in the bug being surface mount im trying to hold everything in place...
Wednesday, 27 November 2013 - 04:53
TWI mega to mega Master to Slave Issues
Hey Guys once again, Mega644PA to Mega644PA on Atmel Studio I've been scouting the forums most of today among a few other places and I can't seem to resolve an issue I've been...
Monday, 17 June 2013 - 08:01
TWI Clock Not Working (Im Pretty Sure)
Hey guys once again! Device: Atmega644PA I've been trying to implement a Two Wire Serial Interface (for future I2C use). Initially I'm trying to make sure my Clock line is working...
Thursday, 13 June 2013 - 04:43

Pages