Post Created date
GCC bugs, could someone test with a recent version?
Finally the bug was confirmed! https://gcc.gnu.org/bugzilla/sho...
Thursday, 19 July 2018 - 06:02
GCC bugs, could someone test with a recent version?
I understand this (that it is volunteer-ran, and may or may not have time for quick fixes), I was rather expecting some feedback, just as much as checking it, marking it confirmed...
Wednesday, 13 June 2018 - 04:53
GCC bugs, could someone test with a recent version?
Thanks for the reports! A week passed, and no response on the GCC Bugzilla, though. Anyway, at least it is there, maybe eventually someone will pick it up.
Wednesday, 6 June 2018 - 04:01
GCC bugs, could someone test with a recent version?
clawson wrote:I wouldn't just do ad-hoc testing. Report to the Bugzilla and let the developers test/reject it more methodically. Chances are Georg-Johan will probably recognize it...
Tuesday, 29 May 2018 - 08:33
PLLDIV seems to be ineffective on an ATxmega128A1U
Thanks, I checked the XMega A manual, and I see: it doesn't contain the divider. Annoying. At least they could have published it in the errata.
Friday, 25 May 2018 - 12:29
GCC bugs, could someone test with a recent version?
I did a test with the Microchip package, the 64 bit bug is still there, however the other seems to be fixed (not sure, it could be that simply the test case no longer triggers it...
Friday, 25 May 2018 - 12:17
[SOLVED] Memory read corruption after disabling interrupts
Interesting discoveries! I think I am pretty much done with it at this point! :) I started to experiment with the relation of the global & peripheral interrupt disable /...
Thursday, 11 October 2012 - 07:40
[SOLVED] Memory read corruption after disabling interrupts
Yeah, maybe I should correct myself, and that's just a warlus, not a whale, and I was a bit dumb there yesterday afternoon :) The weird situations really could happen by that...
Wednesday, 10 October 2012 - 07:02
[SOLVED] Memory read corruption after disabling interrupts
I am dumb or there is not just a fish, but a huge dead rotting whale hidden in there somewhere... So now a more urgent project is over, and I picked up the AVR stuff for some...
Tuesday, 9 October 2012 - 13:52
[SOLVED] Memory read corruption after disabling interrupts
Huh, nice find! I didn't even consider the part after the load! That eor part is after the interrupt enable. That's quite weird since I see no race condition there, and seems to...
Tuesday, 2 October 2012 - 12:15
[SOLVED] Memory read corruption after disabling interrupts
Ah, understood! I wanted to EDIT my prev. post and wondered what happened to the server for dropping me off with "Bad request" (apparently it cant take the percent character, as I...
Tuesday, 2 October 2012 - 11:10
[SOLVED] Memory read corruption after disabling interrupts
Huh, thanks for looking in this! It is strange how it would relate to that problem, but maybe so! I will try to verify once I get the AVR stuff back here. Originally I tried to...
Tuesday, 2 October 2012 - 10:47

Pages