Type in the full discussion title or a part of it.
Discussion Title Created date
megaAVR 0-Series Transition from older ATMEGA
I recently assembled the proto of my first design incorporating the ATMEGA4808 after I briefly looked over all the new and exciting features. I admit it may have been a...
Friday, 13 September 2019 - 01:59
TWI-I2C glitch before ACK creating errors. Not sure what to do next.
I have a system that uses TWI (I2C) for internal communication. There is a single master and 5-7 slaves of various types. 100Khz, 5V, ATMEGA164P as master using TWI hardware, 3k...
Thursday, 8 September 2016 - 20:54
Atmel ICE with AVRDUDE, cannot find device.
I decalared my old AVR-ISPMKII dead a couple of weeks ago. Replaced it with an Atmel ICE that arrived today. It connected and worked just fine on my Win7 Pro / Atmel Studio 6...
Wednesday, 16 December 2015 - 01:44
Is my AVR ISP MKII actually dead?
Hi all...   I have an AVRISP MKII that I have been using for a couple of years with AVRDUDE and Atmel Studio with no trouble. For production tasks I have been using AVR...
Friday, 4 December 2015 - 03:18
Is my AVR ISP MKII actually dead?
******** MOVED TO THE CORRECT FORUM ******** https://www.avrfreaks.net/forum/my-avr-isp-mkii-actually-dead-0   Hi all...   I have an AVRISP MKII that I have been using...
Friday, 4 December 2015 - 02:17
isolating TWI bus on AVR slave that may lose power
Hi all,   I have a multi-AVR system with a TWI bus. One of the AVR's could potentially be shutdown during an expected system fault scenario. The problem with this is that the...
Friday, 13 February 2015 - 07:41
Int to char question
I am trying to understand a little more about what happens when I do arithmetic with one type and put it into another type.    int int_var=4800; char char_var =0;...
Sunday, 14 December 2014 - 05:21
PWM and OVF Interrupt with 16bit Timer
328p 12Mhz GCC   I am struggling to figure out how to get a simple fast PWM LED dimming section of my code to work. The 8bit timers are running other PWM LEDs in the same...
Saturday, 13 December 2014 - 07:01
Using a specific TWI event to trigger an external scope and logic analyzer
Hello all - this is a debug question concerning a TWI bus and how it relates to analog inputs.    I have system using a few AVR's and slave TWI devices. In general, all...
Thursday, 11 December 2014 - 20:57
breaking up an int into individual chars
I am stumped on this. I have managed to get a graphic LCD up and running which was a fun learning experience. I followed the lead of David at edeca.net and have 'nearly' completed...
Saturday, 15 November 2014 - 04:35
AVRISP MKII Works in AS6 but stumbling in AVRDUDE
I have been using an AVR ISP MKII to program from both AS6 and AVRDUDE. Recently, AVRDUDE cannot read any device signatures on any of my boards. Same hardware setup  in Atmel...
Thursday, 6 November 2014 - 07:14
End User programming options
Hi All,   I have a product family that uses 3 AVRMega MCU's inside a single enclosure. This is a portable product that is intended to be used just about anywhere. Early in...
Saturday, 27 September 2014 - 19:44

Pages