Type in the full discussion title or a part of it.
Discussion Title Created date
FATfs - disk_initialize enters infinite loop
Hi. I couldn't find anything about this problem, so I hope you guys could help me. This is how I initialize SD card in my project: // Loop until disk is succesfully initialized...
Sunday, 13 May 2012 - 11:55
condition problem (or whatever i should name this topic)
Hi all... I have a struct defined: typedef struct _GPSData { unsigned char valid; unsigned char updatedFlag; unsigned char hour; unsigned char hour_; unsigned char minute...
Thursday, 10 May 2012 - 13:39
I2C write problem
Hi. I'm currently working on step counter using Freescale MMA8453Q accelerometer. I have a problem with I2C, specifically with I2C_write routine. I'm using Fleury's library. Here'...
Saturday, 28 April 2012 - 18:44
dtostrf() help
Hi all. I have a problem with function dtostrf(). I'm working on a GPS logger. Just for testing, I've created a variable "a", which I want to convert to string and then print to...
Sunday, 8 April 2012 - 13:20
External interrupt on ATMega128
Hi. I'm using the Polar RMCM-01 module to detect heart rate and display it on LCD. The module sends 1ms/3V pulse on every beat. I want to detect it using external interrupt, but...
Tuesday, 20 March 2012 - 16:27
EA DOGM LCD using SPI
Hi. I'm stuck with this problem for almost two weeks, unable to figure out what's wrong. I'm trying to get LCD to work using SPI interface. I've read many threads, datasheets, I'...
Tuesday, 13 March 2012 - 21:00
SPI multiple devices switching (pressure logger)
Hi all. I'm currently working on a simple pressure logger, which will be part of bigger project. Basically, I want to log the pressure and altitude to SD card. I have succesfully...
Thursday, 2 February 2012 - 23:15
switching functions by button
Hi. I have interfaced LM35 with ATMega16 succesfuly. Also I've got LCD to work, so I can print the value on the display. Here is the code (problem will be explained later). #...
Sunday, 25 December 2011 - 22:25
reading signature of ATMega128A failed...
Hi. I know this is quite a FAQ, but anyway. I wasn't able to find the solution of this problem. I'm using an ATMega128A in my project. When I try to read the signature of it, the...
Saturday, 17 December 2011 - 09:20