Post Created date
Xmega128a1 self-programming avr1316
There is definitely a bug in studio 6 simulator.   I have created a working bootloader serial starting from an existing bootloader which work with one of my board. When I say...
Wednesday, 28 October 2015 - 07:49
Xmega128a1 self-programming avr1316
Thanks for your comments. I have discovered the EIND, but with no effect.   I compiled the bandtank bootloader. I will try to see how it works.   Pierre
Tuesday, 20 October 2015 - 08:00
Xmega128a1 self-programming avr1316
Do you use a 128a1u or a 128a1. Can you send me the source code of your bootloader?   Pierre
Monday, 19 October 2015 - 16:55
Xmega128a1 self-programming avr1316
steve17 wrote: Is this a bootloader with all the code in bootloader flash, or are you running code in the application flash and jumping to the bootloader to execute the SPM...
Monday, 19 October 2015 - 06:58
Xmega128a1 self-programming avr1316
Thanks for answer, commenting the .............b.oot result in the code being in FLASH but not in the boot section.   I read that: Application note avr1316.pdf : Since...
Sunday, 18 October 2015 - 09:09
simulator don't display eeprom values in studio6 ATXmega128A1
Making the watch target volatile does not help.
Monday, 2 February 2015 - 15:22
simulator don't display eeprom values in studio6 ATXmega128A1
clawson wrote: It can help to make the watch target "volatile" . Ok I will try and let you know
Monday, 2 February 2015 - 14:53
simulator don't display eeprom values in studio6 ATXmega128A1
clawson wrote: the watch Oh a watch? All the usual caveats apply then ;-)   Might be clear for you, not at all for me!   What can I do, except give up or try my test...
Monday, 2 February 2015 - 13:11
simulator don't display eeprom values in studio6 ATXmega128A1
Thanks for info but AVR-LibC eeprom_read*() or the xeeprom from Autor : Joachim Rath * Revision : initial 04/2010...
Monday, 2 February 2015 - 11:26
simulator don't display eeprom values in studio6 ATXmega128A1
I found it!!!  The answer is simply don't select Preserve EEPROM with the simulator tool.
Monday, 2 February 2015 - 10:30
use of simulator in studio beta 6.2
meolsen wrote:Is this a migrated project by any chance? yes it is, from a previous version of studio (most probably studio 6.1) regards
Wednesday, 30 April 2014 - 12:22
use of simulator in studio beta 6.2
clawson wrote:avr@atmel.com - when you emil that it automatically opens a "support ticket" Done
Wednesday, 30 April 2014 - 09:29

Pages