Type in the full discussion title or a part of it.
Discussion Title Created date
Complementing a bit in PORT
OK, my boolean logic is a bit rusty. PORTB |= 1<<4; // Sets pin4 in a port B and that PORTB &= ~(1<<4); // Clears pin4 in a port B; here must be a simple one liner...
Wednesday, 21 January 2009 - 03:48
Strange goings on using preprocessor directives
Hi All. OK, got my M16 code working 100%, and needed to port it to at90S2313-10 AVR. So, simplest thing to do is to put a #ifdef directive in places required. If I configure for...
Tuesday, 20 January 2009 - 09:53
Suggested improvement for AVRStudio4 Simulator2
Hi. May I suggest that a nice improvement to the simulator2 and AVRStudio4 I/O Reg display would be to add a "Last-UDR" pseudo register which displays the last UDR contents. This...
Monday, 19 January 2009 - 21:49
Either possible GCC 4.2.4 OR AVRStudio4 BUG
Hi All. I am having issues with the following C code not correctly translating under GCC with optimisation turned Off OR It is a problem with AVRStudio4. URD = Data;...
Monday, 19 January 2009 - 21:08
Can standard buildroot fully support new kernel modules?
More specifically: Can the standard avr32 build-root support modules via modprobe, modinfo as it already provides support insmod, lsmod and rmmod utilities? Why I am thinking of...
Wednesday, 19 November 2008 - 02:06
AVR32408 App Note: Linux GPIO Driver
Hi All. Within the above app note, under "Configuring GPIOs in the board setup code" one is able to avr32_select_gpio which assigns a pin and flags, but there is no function to...
Tuesday, 18 November 2008 - 11:08
Kernel Module linking issue questioning at32_select_gpio
Hi All. I have my kernel module using "kernel tasklets" for bottom ISR processing. I compile and get no compiler warnings, rather only a linker questioning at32_select_gpio symbol...
Sunday, 16 November 2008 - 10:21
BEWARE: Anything other than the defaults not Tested
Hi All. :D To save everyone that maybe are having problem getting buildroot-V2.2.1 building different builds, I have received a reply email from Atmel AVR32 support that states...
Sunday, 9 November 2008 - 02:16
what utility fixes: modprobe: cannot parse modules.dep
VFS: Mounted root (jffs2 filesystem). Freeing init memory: 76K (90000000 - 90013000) Mounting virtual filesystems: /proc mounted /sys mounted /dev mounted /dev/pts...
Friday, 7 November 2008 - 07:20
buildroot v2.2.1 - Make problem
Hi All. If I do my "make menuconfig", then "make -j3 all": I get the submake not finding the include directory. "make -j3 all" gcc-4.2.2/gcc/. -I/home/gmkelly/AVR32-Stuff/...
Friday, 7 November 2008 - 04:42
(atstk1006) menuconfig question
config BR2_JLEVEL int "Number of jobs to run simultaneously" default "1" help Number of jobs to run simultaneously What does the configuration...
Friday, 7 November 2008 - 04:00
Problem with UBoot & NFS load.
Hi All :) I am having a very long night/day and I can't see where or what is wrong with uboot not nfs booting from my server. I get the uboot error message: Uboot> nfs macb0:...
Thursday, 6 November 2008 - 00:47

Pages