Post Created date
STK500/525, Serial issue
I was able to make progress with making my flag volatile but when it goes into the isr the timing gets all slow. something that should be immediate is taking over a minute and...
Monday, 16 January 2012 - 21:41
STK500/525, Serial issue
Ok new problem! I can get into the ISR now but I can never leave. Does anyone see anything glaringly wrong? #define F_CPU 8000000UL //8MEG #include #include #include #...
Monday, 16 January 2012 - 20:21
STK500/525, Serial issue
Thanks I was looking through the includes but control f with RXC failed since as you said the C is gone. In the data a sheet it is listed in the table as USART RX but I am new to...
Monday, 16 January 2012 - 18:56
STK500/525, Serial issue
Yes that's always a good idea, I actually had the interrupt commented out at the time and was just polling. But now I am trying to get it working and am having more troubles....
Monday, 16 January 2012 - 18:01
STK500/525, Serial issue
Ok so if anyone cares, I don't know what is wrong with it but it was the ft232. I replaced it by using a of the shelf usb-serial and hooked that to the onboard serial and it works...
Friday, 13 January 2012 - 21:32
STK500/525, Serial issue
I made a light show and I always change the initial transmit so that I can see something new in hyperterm to make sure the new program got loaded properly. Here is the code and a...
Friday, 13 January 2012 - 19:54
STK500/525, Serial issue
I tried a new tack. I set up the portd as inputs and tried tx'ing to it. I got the same result does this mean my uC is fried?
Friday, 13 January 2012 - 18:09
STK500/525, Serial issue
This is what the tx coming out of the ft232r looks like when not connected to the uC.
Friday, 13 January 2012 - 17:12
STK500/525, Serial issue
I had set some grounds but it wasn't ideal so i re-grounded everything and this is what I get. (basically no change but much less noise.)
Friday, 13 January 2012 - 16:25
USART declaration problem (90USB1287)
Without changing anything it started working but I am having baud rate problems. Thanks for the help :)
Friday, 13 January 2012 - 14:58
USART declaration problem (90USB1287)
Ok, I got that code to compile but it doesn't actually function. My setup is sending the signal to a ft232r which is connect to my pc and then I have hyper terminal setup. I did...
Friday, 13 January 2012 - 14:49
USART declaration problem (90USB1287)
Solved. The datasheet example code is wrong. It says "UBRRHn = (unsigned char)(baud>>8);" but should say "UBRRnH = (unsigned char)(baud>>8);"
Thursday, 12 January 2012 - 20:39

Pages