Type in the full discussion title or a part of it.
Discussion Title Created date
atof brain fog SOLVED
Cannot see my error. Atof (bottom of function) is returning odd values. void parse_string(void) { char NEMA[8]; char UTC[11]; char DATE[7]; char LATITUDE[10]; char...
Tuesday, 3 July 2012 - 22:32
Can't find .hex output
Computer blew up and finally back in the saddle after more than a month. I had just transitioned to AS6 due to the JTAGICE3 not working with AS4 or 5. Made a code change, did a...
Sunday, 1 July 2012 - 00:39
Cranky USART SOLVED
2560 USART. All is OK unless I try to transmit a character 0x60 or higher. It sends characters much higher in the ascii table. I cannot see any kind of bit shifting or logical...
Sunday, 20 May 2012 - 02:37
USART UBRRO calculation oddity
// Define baud rate #define Fosc 3684640// System Oscillator clock frequency #define BAUD 9600 //not really needed if you want to program the UBRR directly #define...
Saturday, 19 May 2012 - 18:18
Anyone know how to get Atmel to fix my AVR ONE!?
I cannot get an RMA or address. They keep asking for screen shots. The power connector is bad and it will not talk to anything. I just want to get it sent in for repair. In...
Monday, 7 May 2012 - 23:32
What is my error?
So, back in the Atmel saddle today after a 6 month break. First time I got my draft code to compile. Now it has a make error. But I am not well enough versed to figure out what...
Thursday, 19 April 2012 - 21:06
Bricked 88a?
I have a target that is still working, but when plugging in the AVR ONE! it says the clock freq is too high. I was trying to program a second target via onboard ISP when I got...
Monday, 16 January 2012 - 03:04
compiler hell
GCC is giving me fits. Choose one type of optimization and it loads my USART register from CPU registers that never get loaded with the proper number. Anywhere. I searched the...
Saturday, 23 July 2011 - 17:15
STK 600 and AVR ONE! Interoperability
After weeks of trying I finally cracked the process (thanks to some cricial clues proffered by Clawson). There are some odd things that are essential to know if you have never...
Monday, 20 June 2011 - 20:35
[ solved ] STK600 Horrible Jitter
Beware, the 0-32.7 MHz clock source on the STK600 has horrible jitter and a horrible waveform. Not even approaching a square wave. Kinda a kindergarden sawtooth waveform. Do not...
Sunday, 19 June 2011 - 02:32
_delay_ms(speed);
Works just fine with winavr toolchain. int speed; Does not work with avr toolchain. Avr toolchain expects a constant parameter. Any way to fix that or just use winavr all the...
Saturday, 18 June 2011 - 18:21
Problem with ATmega88PA PC2?
Third chip now, internal pull up resistor does not do its job. Is this a known problem? If so I have not stumbled upon it by searching. AS4/GCC Will have to take a look at...
Friday, 17 June 2011 - 22:28

Pages