Post Created date
Optimizing problem
ellile wrote:How do you add the WINAVR version into AS5?Select Tools, then Options.... Expand Toolchan (at the bottom) and select Flavour Configuration. In Toolchans: select...
Wednesday, 28 March 2012 - 14:28
Optimizing problem
ellile wrote:Her is the .lss fileI don't see any attachment. ellile wrote:I am A littlebit frustrated at the moment.I can relate to that. This looks like it might be the same or...
Wednesday, 28 March 2012 - 12:26
Compiler Bug: incorrect code generated with -Os
stevech wrote:"IINCHIP_READ" looks like adaptation of WizNet's code for their ethernet modules. (I use them, though I don't use their code).Yes, that's what it is. I've done a...
Wednesday, 28 March 2012 - 12:04
Compiler Bug: incorrect code generated with -Os
david.prentice wrote:IINCHIP_READ() looks like a macro, so it may not evaluate to a strictly typed expression.My first thought was that IINCHIP_READ was a macro too. It's not,...
Tuesday, 27 March 2012 - 16:06
Compiler Bug: incorrect code generated with -Os
Here's a couple of additional observations. There are 7 places in the code (which, by the way, isn't mine) that use nearly identical constructs. That is: val0 = IINCHIP_READ...
Tuesday, 27 March 2012 - 14:37
questions about AVR + fix my code
Koshchi wrote:AVRs address memory byte-wise, so accessing a 16 bit variable is not atomic.For atomic access of 16-bit variables, I use #include and a function like this: static...
Sunday, 5 February 2012 - 20:04
Xbee Problem
modderman wrote:I am using the internal oscillator. If I need an external clock what do I need to set it at?Torby wrote:The easy suggestion would be, "Whatever frequency you're...
Saturday, 28 January 2012 - 20:07
Xbee Problem
There's a lot more that goes on between two Series 2 XBee modules than just your transmitted data. You probably have one module set up as a coordinator and the other as an end...
Friday, 27 January 2012 - 13:47
Switching from ATmega128 to ATmega64
Koshchi wrote:And if you go with the mega644, it is even less.A while back, I ported the WIZnet W5100 Ethernet controller software from an ATmega128 to an ATmega644. I don't...
Tuesday, 24 January 2012 - 16:41
No Address Ack from Slave, USITwi, AVR310
davethomaspilot wrote:Ok, thanks. But, after I added the delay between the master forcing SCLK low and forcing SDA high, everything is working reliably using the BlinkM as a...
Sunday, 27 November 2011 - 17:11
PCB Cleaning soloutions for heavy flux
leon_heller wrote:Iso-propyl alcohol.The first thing that came to mind was India Pale Ale but I figured that couldn't be correct. Don
Saturday, 26 November 2011 - 21:42
AVR Sleep mode and indicator LEDs
smileymicros wrote:So is it general practice to have a special pre-sleep routine to go around and shut off all the lights before going to sleep? Or am I missing something.I couldn...
Thursday, 24 November 2011 - 17:46

Pages