Type in the full discussion title or a part of it.
Discussion Title Created date
mega169 I2C hair-pulling session
I need to talk to an I2C proximity sensor, using a meag169 at the uC. I'm using Studio 7. I have a fairly complex project started in Studio 7 that originally used a different...
Tuesday, 5 March 2019 - 01:07
eeprom window displays question marks
I am developing a tiny4313 project, using Studio 7.0.1645. I have been working on this project for a while now, using an AVR Dragon as my debug interface. Yesterday, I wanted to...
Friday, 5 October 2018 - 18:11
Studio 7/mega169/JTAG can't remove "phantom" breakpoints
I'm trying to debug a mega169 project (not a Butterfly board) using Studio 7.0.1645, and when I run with the AVR Dragon as the debug tool, the program keeps halting at a place...
Tuesday, 21 August 2018 - 19:08
Bebugger breaking with no breakpoints set
I am using S7.0.1645, the target is a mega169 (not a Butterfly board!) and the debugger is AVR Dragon. In general, things are working OK, but I started having an odd problem. With...
Wednesday, 15 August 2018 - 19:18
mega169 ADC not working
I'm developing a project which requires the use of the internal ADC to monitor battery voltage. I had designed a "breakout board" for the mega169 to allow access to the various I/...
Wednesday, 1 August 2018 - 23:23
LCD registers and JTAG
I am starting a project using a meag169PA to drive a custom LCD display, and obviously, I'd like to use the built-in LCD driver, but a couple of issues have surfaced. 1. I use the...
Tuesday, 12 June 2018 - 02:00
mega328 async interrupts half-speed
I have a project using a mega328. The main clock is the 8 MHz internal, and I have timer 2 running asynchronously with a 32.768 KHz watch crystal. I have a very simple program...
Friday, 1 September 2017 - 04:25
How to change the %$#*#$ F_CPU in AS7/Arduino
OK, I've seen some other other threads about this, but nothing that seems to be definitive for me (at least, so far I cannot seem to make it work!). I have an Arduino sketch that...
Thursday, 31 August 2017 - 18:53
Error message: "error reading variants path"
I have Atmel Studio 7.0.1417 running on a W10 laptop. I would like to make a project using an existing Arduino sketch that compiles and loads correctly on an Uno. I am confused...
Wednesday, 30 August 2017 - 22:47
AVR Dragon will only do one action before requiring target reset
I have used the AVR Dragon for many years, with a variety of Atmel devices, and with a variety of computers and "flavors" of Windows. Just recently, I had to work on a project for...
Thursday, 10 August 2017 - 04:49
Can't start an Arduino-based project any more
I am running Studio 7.0.1188 on a W10/64 bit system. I have successfully done projects with Arduino sketches in the recent past. I recently "updated" to Windows 10 "Creator", and...
Monday, 17 April 2017 - 21:16
Error when compiling imported Arduino project
I'm running Studio 7.0.1188, and I am trying to import an Arduino sketch that compiles successfully in the Arduino IDE (version 1.6.12). Creating the project goes smoothly, but...
Thursday, 23 February 2017 - 22:43

Pages