Post Created date
SIMPLE ADC
I've moved the ADC input port to ADC2. I am not sure why it did not work with ADC0 but I think it has something to do with RESET. Can you guys please explain why this is...
Thursday, 12 August 2010 - 20:21
SIMPLE ADC
Quote:Which prescaler? Are you talking about CLKPR. When the CKDIV8 fuse is set it just arranges for that register to default to /8 and 9.6MHz becomes 1.2MHz. If you have changed...
Thursday, 12 August 2010 - 19:07
SIMPLE ADC
clawson wrote:Quote: but I see CKDIV8 bit checked. Does this mean the actual clock I will be using is 9.6 Mhz divided by 8 Yes 1.2MHz I've changed the prescaler to 4 so that my...
Thursday, 12 August 2010 - 18:05
SIMPLE ADC
KitCarlson wrote:With the Tiny13, a debug method might be to setup a PWM and feed the ADC to it. This is very simple to do. A scope can then be used to read the ADC value via a...
Thursday, 12 August 2010 - 17:56
SIMPLE ADC
Simonetta wrote:Try variations of the program. For example, do a single conversion (instead of free running) 50 times a second. What is the VCC of the Tiny13 when the pot goes...
Thursday, 12 August 2010 - 17:42
SIMPLE ADC
thanks for your replies. I'm using VCC as my reference voltage, am I not? ADMUX &= ~(1 << REFS0); // Set ADC reference to VCC I think by observing that the transition...
Saturday, 7 August 2010 - 05:24
SIMPLE ADC
Is there something wrong with my question format? I need help on this. I don't have debugger tool to debug where the logic error is coming from.
Friday, 6 August 2010 - 16:04
Simple push button and simple LED out does not work
Thanks. Nice explanation and it totally makes sense to me. Thanks alot!
Friday, 6 August 2010 - 14:57
Simple push button and simple LED out does not work
It seems to work. I haven't found any info on pulling up the input yet.
Thursday, 5 August 2010 - 20:58
[TUT] [C] Newbie's Guide to the AVR ADC
I followed your example but am having a bit of problem. https://www.avrfreaks.net/index.p...
Thursday, 5 August 2010 - 20:32
Simple push button and simple LED out does not work
https://www.avrfreaks.net/index.p...
Thursday, 5 August 2010 - 20:15
Simple push button and simple LED out does not work
OK I've changed my input to the pin4 to GND from 5V and it now works. Thanks everyone. :) Problem solved. I'm going to post another question related to ADC. I'll post the link...
Thursday, 5 August 2010 - 19:52

Pages