Type in the full discussion title or a part of it.
Discussion Title Created date
c++ creating a "Button" class
There has to be a neat and and graceful way to do this.   I already have a "Screen" class for drawing a display on a tft display. I'd like to make a "Button" class for...
Thursday, 4 April 2019 - 22:53
ZeptoProg AVR Programmer?
Anybody use this programmer? Since my Atmel-Ice died, I'm looking around.   https://www.mattairtech.com/inde...
Wednesday, 27 February 2019 - 16:40
"Pit Boss" grill temperature probe
Trying to use one of these to measure temperature, but having no luck. It doesn't behave like a K type, or a J type thermocouple. Wonder if it's actually an LM35 or somesuch. It...
Thursday, 31 January 2019 - 19:29
Thermocouple amplifier always gives same output
I have 2 of Adafruit's analog thermocouple amplifiers:   Analog Output K-Type Thermocouple Amplifier - AD8495 Breakout   and 2 thermocouples.   Though I have one in...
Wednesday, 23 January 2019 - 21:59
ili9341 suspicious looking library code
I can't seem to draw anything below z=255 using this library and I suspect this bit of code:   void ili9341_setaddress(uint16_t x1,uint16_t y1,uint16_t x2,uint16_t y2)//set...
Monday, 14 January 2019 - 21:50
I think my integrated motor driver chip shorted.
My train controller is a short circuit from + to -. The H-bridge, VNH5019A, seems to be a short. It was rated for 5 amps, the battery shuts down at 7 amps and there's a 5A fuse. I...
Wednesday, 15 August 2018 - 20:05
24vac valves and motors
I just looked at a contraption with 24v AC motors and solenoids controlled by relays. As expected, it goes mildly haywire when he turns one of these motors on or off. If it was DC...
Thursday, 1 February 2018 - 19:25
LM2840 CBoot capacitor
Searching the data sheet, I don't find anything about the voltage needed for the CBoot capacitor.     I design train related things for 10 to 30 volt input. ...
Thursday, 9 November 2017 - 22:51
Mega328 timer 2 interrupt
As soon as I set the TIMSK to enable timer 2 interrupt, my program stops working, so obviously, I've overlooked something:   Setup routine: void setup() { pinMode(...
Monday, 3 July 2017 - 15:59
Can't debug my Arduino Nano with Studio 7
Eek!   I imported and built my sketch. Programmed the arduino using my Atmel ICE. Of course the program isn't working, that's why I'm trying to debug.     But when...
Monday, 3 July 2017 - 14:55
Funny how that works....
Working on an Arduino project for a magazine article. Was just about working right, and I decided to make a small change in the program. Now it's completely doing nothing like it'...
Sunday, 19 March 2017 - 21:16
"High" is half a volt?
I've been using some TSOP2438 infrared receivers to detect trains and the like blocking flashing IR LEDs for quite a while now, but I've been stuck for several days on a project...
Monday, 20 February 2017 - 20:57

Pages