Type in the full discussion title or a part of it.
Discussion Title Created date
Atmega 2560 Fuse Bits Changed during normal use.
I've had two customers send non-working instruments (out of about 80 total). These came back with the low fuse bits cleared!   Simple reprogramming fix but how does this...
Thursday, 6 May 2021 - 15:57
2560 Bootloader using any terminal program
Attached is my 2560 Bootloader.   Advantages: 1) No special program on host PC. Uses any terminal program to send the hex file via the serial port. I use TeraTerm (File |...
Monday, 8 March 2021 - 15:24
EVENT Counting on input PIN in AVR128DA64 Nano Curiosity
I've got a AVR128DA64 Nano curiosity board, and wanted to test counting input pulses. So first thought I would try this using the switch input, PortC pin 7, and link it through...
Thursday, 7 January 2021 - 20:30
CLK_CPU on AVR Dx
I'm looking at the CPU Clocks on the AVR DA and DB, and wondering if there is any reason (for me) to use an external crystal.  The data sheets have auto tuning or user tuning...
Sunday, 15 November 2020 - 15:15
Learnign curve 8-bit AVR to 32 bit AVR or ARM/SAM?
My basic question is for my next project:  pros and cons of sticking with 8-bit AVR? Switch to an SAM/ARM?  Stick with Studio 7 or switch to MPLAB-X? I also have a Keil...
Wednesday, 11 November 2020 - 01:54
Is FatFS file system robust?
Is the FatFS file system robust or is it my SD cards?   I'm using the Fatfs file system on an ATmega2560 to write to an SD card via an SPI bus.  fopen, fclose, and...
Thursday, 14 May 2020 - 16:17
4 or 8 second WDT on ATMEGA 2560 not working
Using stidiuo 7 and gcc to program and ATmega2560. The WDT works fine up to 2 seconds. If I try 4 or 8 it doesn't work. using library routines:   #include <avr/wdt.h...
Thursday, 2 April 2020 - 13:24
ICE Disconnects when Jtag plugged in.
I've got a new board I'm trying to program.  Running Studio 7, ICE firmware up to date, programming a ATmega 2560.  The ICE shows up in the Device Programming window...
Tuesday, 23 July 2019 - 16:58
Dragon not recognized by Studio 7
Just got the Dragon but I cannot get ATMEL Studio 7 to recognize the Dragon. Running Windows 10 (new computer).  Latest Studio 7-when it was installing it indicated the USB...
Wednesday, 16 December 2015 - 01:21