Type in the full discussion title or a part of it.
Discussion Title Created date
bitshifting with variable bitmask problem
Hi ! I have got a little problem with understanding bitshifting. That type of code is working: unsigned char shbyte=0b01010101; unsigned char shcnt=0; void shiftingTest(void...
Sunday, 19 January 2014 - 11:10
ICNova ADB1000 / AP7000 OEM plus beginner questions
Hi! I am a beginner with AVR32 and now i have a problem ! I have crashed my kernel on AP7000 OEM plus modul... I made: flash_eraseall /dev/mtd0 flash_eraseall /dev/mtd1 dd if=...
Wednesday, 18 April 2012 - 07:50
question on struct
Hi there ! I have a questin about structures.... if i use an array for my values then what i want to do looks like that..... uint8_t i; char *val[10]; char *valout; val[1] = "...
Tuesday, 26 January 2010 - 12:00
XMega EEProm pageadress & byteadress
hi all.... i have a question about NVM.ADDRn registers. i do not know how to select a page adress and a byte adress can someone can give me an exsample how to write ADDRn...
Thursday, 21 January 2010 - 12:16
atxmega usart problem
hi all.... i have got a false timing on my usart and i dont know where my failure is.... is there a generally timing problem ?!? i think the problem hav to do with USARTC0....
Thursday, 14 January 2010 - 12:53
just an other xmega question
Hi there i want compile an xmega32a4 with avr-gcc my problem is: error: MCU "˜atxmega32a4' supported for assembler only does avr-gcc realy only support atxmega128a1 in c ?!? or...
Wednesday, 13 January 2010 - 09:46
problems with avrispmk2 avrdude and xmega
Hi there.... now i got a new problem.... if i want to read data of an xmega32a4 via avrdude i got the following error (false device signature[000..]) avrdude: Version 5.8cvs,...
Tuesday, 12 January 2010 - 13:30
XMEGA USART which bscale ?
Hi there.... I have got a question on Xmega Usart... A friend have told me that configure an usart with a positive bscale is better then a negative bscale... My question is: Is it...
Monday, 11 January 2010 - 14:03
Problems with XMEGA pll and clock system
Hi there ! I have som problems with XMEGA pll and clock system and some problems with the generally understanding. First my code....: #include #include #include #define...
Thursday, 7 January 2010 - 10:16
some problems to forward a 0......
Hi there ! I have got a real big problem to forward a 0 to my funktion.... Here is the Code: void sendCmd(uint8_t cmdindex, uint8_t *param) { char dsplout[MAXLEN]; uint32_t...
Tuesday, 22 September 2009 - 10:34
arrays and pointers are making me crazy! HELP!!!!
hi there i think i'llnever understand av-gcc i have got another question. this code seems to work, but i have got a warning i do not understand and dont know how to fix it or make...
Friday, 18 September 2009 - 12:02
problem on arrays
hi there ! i have some problems on forwarding a char array to a funktion... i am very new in avr-gcc and i do not knowwhat i can do... here is the code : i would be very happy if...
Thursday, 17 September 2009 - 11:40

Pages