Post Created date
Switching an Arduino Leonardo to DFU
Ok so sounds like the simple option is to set HWBE and use the /HWB pin - but that isn't possible on these boards because SparkFun designed them with it always grounded - doh!...
Sunday, 23 March 2014 - 22:46
Troubleshooting a programming circuit?
That's not to say I think you're fibbing, just in this case it doesn't seem to require them! As I say, if I design for PCB I shove them in, because you can slip in an 0805...
Wednesday, 15 June 2011 - 15:00
Troubleshooting a programming circuit?
I tried a couple of ceramic 100nF's, but they didn't work by themselves (kept getting a device sig of zero). Re-inserting the two electrolytics did, however. Both together works...
Wednesday, 15 June 2011 - 02:54
Troubleshooting a programming circuit?
I've added a 22uF (all I had immediately to hand...) across each pair of pins which has solved the intermittent detection - thanks! This may sound dim, but I've never used bypass...
Wednesday, 15 June 2011 - 00:57
Which package to use for a Mega328
I'm using the same datasheet version as you, doc8271. I just assumed that the 32QFN would be square, not with the chamfered corners - given that the 28QFN doesn't have them. Guess...
Sunday, 27 June 2010 - 19:09
Unexpectedly fast ticks using Timer2?
When you say that far off, as in i should get another crystal or a new clock method entirely? On the package it does say 4.000 so i would at least expect that kind of accuracy....
Sunday, 27 September 2009 - 16:37
Unexpectedly fast ticks using Timer2?
Yep it's definitely running from the crystal - i had a moment of panic when i couldn't program the chip and then i realised it was because i hadn't plugged in anything to the XTAL...
Sunday, 27 September 2009 - 16:13
Unexpectedly fast ticks using Timer2?
Ooh, nice catch! It's still running a bit fast though, perhaps 1.5x too fast? But, nowhere near as bad as it was. I guess i could tweak it, but that would seem like fudging when...
Sunday, 27 September 2009 - 15:48
AVR "remembering" code, even after erasing and ref
@Christopher - sorry, i thought it was implied, i did of course change the makefile when i switched processors over (i did upload the wrong version by mistake once, but it just...
Thursday, 24 September 2009 - 14:33
AVR "remembering" code, even after erasing and ref
I've tried all of the above in AVRDude (aside from blank check - how would i do that?) It passes every one and still doesn't work :)
Thursday, 24 September 2009 - 07:18
AVR "remembering" code, even after erasing and ref
Nope, as i said the new hex file works with a different chip. The new file is also trimmed down to about half the size so can't possibly be the same. I'm writing it up in notepad...
Thursday, 24 September 2009 - 06:45
High Voltage Programming for ATMega128
I have a similar problem, apologies and i don't mean to thread hijack. (ATMega168 btw) My USBasp came in the post today and i thought i'd get going, i tried out a basic "blinky"...
Tuesday, 22 September 2009 - 22:26

Pages