Post Created date
Studio 7 doesn't break on breakpoint in assembly code
darulezy wrote:Studio 4 works OK in windows 10 but you have to uninstall Studio 4 & 7 and manually delete the driver files then re-install studio 4.   Studio 4 doesn...
Wednesday, 15 June 2016 - 07:14
Studio 7 doesn't break on breakpoint in assembly code
I solved by simply not using studio 7. Fond an old Windows XP cd, set up a virtual machine and installed Studio 4. It's so dumb that Studio 7 can't debug assembly that I think we'...
Thursday, 9 June 2016 - 06:51
How to re-enable SPI with Studio 7 and Atmel-ICE
meolsen wrote: Go to Tools->Select Profile and apply the advanced profile. It should then reappear.   That did the trick, thanks.
Friday, 27 May 2016 - 06:46
AVR Studio will not find AVRIPSmkII
Fast forward from my previous message stating I got a solution to present day and again no way to have mkII recognized by windows. I spoke with a local atmel support and they told...
Tuesday, 19 April 2016 - 09:07
Alter the program counter via Studio 7 GUI
Wow, that would be a huge feature, I wasn't aware of that, thanks.
Monday, 21 December 2015 - 20:08
Alter the program counter via Studio 7 GUI
I just need to know where in the code the function was called.
Monday, 21 December 2015 - 19:40
Alter the program counter via Studio 7 GUI
I don't care. My fault function is a non exiting function and the firmware loops indefinitey in it. The only way to exit from fault is by switching off the equipment. I need a way...
Monday, 21 December 2015 - 12:22
Alter the program counter via Studio 7 GUI
I wrote the PC in the processor status window. The new PC you wrote points to a piece of code in the same file you have already opened? Can you please try to write a PC that...
Monday, 21 December 2015 - 11:02
Alter the program counter via Studio 7 GUI
@meolsen: I tried to issue 1 step, but it doesn't work. I don't uderstand what you mean with jump back in the stack.
Monday, 21 December 2015 - 10:28
Alter the program counter via Studio 7 GUI
Yes, of course. As I wrote at the beginning of the function I read the stack to save the calling address of the fault function: typedef union { ulong long_data; uchar byte[...
Monday, 21 December 2015 - 09:26
AVR Studio will not find AVRIPSmkII
I solved my problem installing the latest Studio 7 and then this drivers: https://gallery.atmel.com/Produc... With them I can now run Studio 4 for my olf JTAGICE mkII and...
Thursday, 17 December 2015 - 07:31
AVR Studio will not find AVRIPSmkII
I switched to windows 10 some time ago and today I wasn't able to work with my JTAGICEmkII and AVR Studio 4. I checked in device manager and I only see a Windriver under Jungo...
Monday, 7 December 2015 - 09:32

Pages