Type in the full discussion title or a part of it.
Discussion Title Created date
Porting from IAR
Hi, I am porting a project from IAR to Studio 5 and am having a hard time finding things. In WinAvr there was a header file for the processor that had all the defines for the...
Friday, 11 November 2011 - 20:17
More ADC trouble
Hi everyone, I am getting bleed through on adjacent ADC channels on my 16A4 project. I have 8 analog inputs which I convert 4 at a time. Here is the relevant code: void...
Thursday, 6 October 2011 - 18:36
unsigned math problem
I am in over my head on some unsigned math. struct adsr { uint32_t attack; uint32_t decay; uint32_t sustain; uint32_t release; uint32_t accum,accum2; uint32_t curDac;...
Thursday, 22 September 2011 - 17:55
can't compile mega164 code? (solved)
Hi, Why can't I compile for the mega164? I have the latest WinAVR-20100110. Is that the latest? seems oldish. What have I missed? --TimR
Monday, 15 August 2011 - 16:11
xmega32A4: how many ADC inputs?
Hi, According to the xmega32A4 datasheet there are 12 ADC inputs: 8 on port A and 4 on port B, labelled ADC0-11. So I designed a circuit with an xmega32A4 using all the ADC pins....
Wednesday, 3 August 2011 - 13:57
Help with pin change interrupts
Hi, I am trying to get pin change interrupts to work on a mega644. I am using PA0-2 as analog inputs (ADC), and PA6-7 as interrupt inputs. I get one interrupt at the beginning of...
Tuesday, 19 July 2011 - 17:29
Trouble starting debug session
Hi, (Sorry if this is a duplicate post. The search function seems to be wonky at the moment) I am having trouble starting a debug session in AVR Studio 4 (4.18 684). I used to...
Monday, 18 July 2011 - 15:12
WinAVR: Newest?
Hi, I went to get the latest WinAVR and the newest one is from Jan 2010. Is that right? Am I missing something? --TimR
Sunday, 12 June 2011 - 18:08
Max memory available?
Hi everyone, I have some code where I need a big array. When I maxed out RAM with the array the code operated oddly. Turns out the stack I am guessing was scribbling over my...
Monday, 14 March 2011 - 18:36
AVR + Audio DAC?
Hi, has anyone interfaced an audio DAC to an AVR? I'm talking a Sigma-Delta type DAC like the CS4344. They have a funky interface that requires 2 synced clocks. Thanks in advance.
Thursday, 27 January 2011 - 16:46
Xmega ADC question
Hi, I am trying to use the virtual channel function of the ADCs but I can't get it working. Do I need to have the ADC in free-running mode to get the virtual function to work?...
Wednesday, 12 January 2011 - 18:12
XMega timer troubles
Hi, I am trying to set up a timer on an XMega192A3 to produce a 256KHz (3.9uS) interrupt. Here is my timer code: // timer TCC1 is the DAC clock timer TCC1.PER = 0x007C; TCC1...
Saturday, 8 January 2011 - 01:01

Pages