Type in the full discussion title or a part of it.
Discussion Title Created date
power supply glitches
Hi Friends, I am working on a project that uses feedback and corrective action for a positioner. The ADC0 and ADC1 inputs of ATmega8 working at 8 Mhz, are used for set voltage and...
Tuesday, 31 March 2015 - 09:09
can't detect STK 500
I had to format the hard disc and reload "AVR-Studio-4" on my Laptop. Initially I had lot problems, but eventually understood that v 4.19 had some built in bugs for simulation. So...
Tuesday, 25 February 2014 - 06:34
hex to .asm or .c conversion
Hi everybody, I had written a dot c file for one of my project that uses atmega644 ic.I use avr studio4 and stk500 kit. However after loading the program into my IC, I...
Thursday, 29 September 2011 - 02:45
SPI slave
Hello, I am trying to use the ATmega16 as master and ATmega8 as slave connected to each other in SPI interface. Master SS pin is hardware pulled up by 10k resister. Slave SPDR...
Wednesday, 6 April 2011 - 02:17
how to switch between two functions
I am using ATmega16 in one of my project and the main program has two different functions.....lets say first function counts and displays only odd numbers 1,3,5...99,1,3 etc and...
Monday, 21 February 2011 - 09:29
want to know about optimisation
Hi all, I am using AVR studio version 4.18 build 684, with WINAVR20090313 for writing a program using ATmega16 device. I am trying to use following two functions, one for...
Friday, 27 August 2010 - 13:40
which optimization?
Hi all, I am using AVR studio version 4.18 build 684, with WINAVR20090313 for writing a program using ATmega16 device. I am trying to use following two functions, one for...
Saturday, 24 July 2010 - 04:11
avr hangs anytime
I am using ATmega16 - AVR STUDIO4 assembly language program- for one of my project, this main cpu gets the information about a motor speed on its serial interrupt (through another...
Sunday, 15 November 2009 - 04:10
jumps wrongly
I am using avr studio4 IDE and am using its simulator.I have enabled the INT1 and global interrupt.When the INT1 pin L to H transition is sensed, the program jumps to TIM2OVF...
Friday, 12 June 2009 - 15:37
jumps wrongly
I am using avr studio4 IDE and am using its simulator.I have enabled the INT1 and global interrupt.When the INT1 pin L to H transition is sensed, the program jumps to TIM2OVF...
Friday, 12 June 2009 - 15:36
beginner facing problem with SPI
I am a beginner for AVR, am using a master(ATmega16) that communicates with slave(ATmega8)on SPI.While I am sending six bytes, I can see six clocks and data pulses on my scope on...
Friday, 12 June 2009 - 15:25