Type in the full discussion title or a part of it.
Discussion Title Created date
IO1 Xplained Demo - wrong register type defined for AT30TSE758
There's a Start example for using a SAM D21 Xplained Pro to measure temperature, from the AT30TSE758 sensor on an I/O1 Xplained Pro extension board. The code appears to define...
Sunday, 9 May 2021 - 02:26
Set Next Statement workaround: debugging on the simulator in Studio 7.0.2542
I've filed this with Microchip. Until a fix is released, the following may help.   There seems to be a reproducible error in Set Next Statement. The following are affected; I...
Tuesday, 30 March 2021 - 23:18
ATtiny214 debugger Memory SRAM doesn't update?
I filed a bug for this but mention it here in case anyone else is tearing their hair out. Simple demo case is New Project - I'm using an avr-gcc C executable - which creates...
Friday, 26 March 2021 - 06:25
Run to cursor in Microchip Studio 7?
Can anyone confirm that "Run to cursor" has been completely removed please? Its icon changed in previous versions of Studio, and it's been on and off the Debug default toolbar....
Thursday, 25 March 2021 - 22:07
TWI slave state-machine vs SCTRLB for ATtiny 1-Series
(I'm targeting an ATtiny214 but the TWI slave section of the Rev C datasheet seems common to other 1-Series. There are no applicable TWI errata for that revision.)   Can't...
Thursday, 4 February 2021 - 18:35
Debugger - continue from address?
I'm using Studio 7.0.1931 to debug assembler. The only way I've found of skipping to a given address, then continuing execution from there, is this:   - start a debug...
Saturday, 3 November 2018 - 07:58
[newbie] Butterfly LCD - system or async clock?
In the LCD Demo app for the Butterfly, the LCD_Init routine sets up LCDCRB, the ATmega169's LCD Control and Status Register B, like this: LCDCRB = (3<<LCDMUX0) | (7<...
Monday, 8 December 2008 - 04:44
LCD toolbar greyed out
I'm using Studio 4 4.15 build 623 and LCD Visualizer version 1,0,0,13. At first Studio found the Visualizer plugin, but the Visualizer plugin toolbar would blink then disappear....
Sunday, 7 December 2008 - 05:42