Post Created date
UC3C PWM Question
wedgen wrote:In my project, I only required 1 of the 2 PWM channel output signals, by that I mean I only required the High line and not the Low line. Is it possible to not...
Friday, 16 March 2012 - 10:36
need help explaining a pointer
Actually, you'd use: AVR32_FLASHC.fcr = (some combo of bits and values); since atmel included the leading * in the definition of AVR32_FLASHC. Even more confusing, I know.
Wednesday, 14 March 2012 - 00:30
AVR32 C Compiler Calling Conventions
I agree with everything catweax said above and will add one more piece of potentially important information. With functions that return a value (in R12 as stated above) gcc...
Wednesday, 14 March 2012 - 00:24
Instruction Format document 32000.pdf
9.2.6?
Thursday, 8 March 2012 - 01:40
Problem with Timer Counter Output on EVK1100
Writing the same values is not necessarily the same as not touching the regsters at all. I've used the UC3 TC a number of times and have never seen the behavior you describe.
Saturday, 25 February 2012 - 21:17
Problem with Timer Counter Output on EVK1100
I don't see anything wrong in the code you posted. Are you touching any of the TC registers after init as your program runs? If so, I'd temporarily disable that code to see how...
Saturday, 25 February 2012 - 11:25
Problem with Timer Counter Output on EVK1100
The schematic http://www.atmel.com/Images/EVK1100_SCHEMATICS_REVC.pdf says that PX14 is connected to the chip select input on the SDRAM. I wouldn't think that would be a problem...
Thursday, 23 February 2012 - 23:49
Problem with Timer Counter Output on EVK1100
What pin(s) are you using for PWM output?
Thursday, 23 February 2012 - 11:37
SDRAMC and SMC at the same time?
#define WIZNET_ADDR_BUS_WIDTH 15 // specify the memory cycle timing parameters in ns #define NWE_SETUP 15 #define NCS_WR_SETUP 15 #define NRD_SETUP 15 #...
Thursday, 23 February 2012 - 00:01
SDRAMC and SMC at the same time?
I used EBI on UC3A0512 to interface a Wiznet module and an FPGA that presented an SRAM interface. The wiznet was connected to chip select 0 and so appeared in the UC3's data...
Wednesday, 22 February 2012 - 13:19
Register issue
Did you set the flash for 1 wait state when operating above 33 Mhz? Neglecting to do so can cause all sorts of weird issues.
Saturday, 18 February 2012 - 11:53
Internet connection via cell phone
You might have better luck with this question here: http://www.at91.com/
Wednesday, 15 February 2012 - 11:09

Pages