Type in the full discussion title or a part of it.
Discussion Title Created date
Delay after ADC conversion complete.
I have seen some posts where it shows a delay after the CH0IF flag is set (signalling conversion complete) and before reading CH0RES. I can't seem to find anything about this is...
Saturday, 9 February 2013 - 01:03
Watch byte bugs [workaround]
When watching variables defined a .byte 1 or .byte 2 the Watch shows then a double words regardless of their size. Also it shows the ADDRESS of the variable instead of the VALUE.
Friday, 8 February 2013 - 04:00
AS6 Help "Product page for tool" greyed out[solved
Is it just me? The above is greyed out and I can't get to the tools help screen. Just as well the trusty AS4 is also installed. :-)
Wednesday, 6 February 2013 - 21:17
Project folder bug??
I created a folder and copied all the files I wanted from another project which will then be modified accordingly for a new project. Now I create a new project in THAT FOLDER and...
Saturday, 19 January 2013 - 08:40
ADC issues (now Xmega256A3BU)[Given up]
So I'm not the only one with this kind of "issue". The ADC calibrations seems to be nonsense as the values are 0 in the signature byte. This no longer works in AS6 // Read low...
Monday, 14 January 2013 - 02:28
Stopping timers on break.
How do I do that with AS6 and JTAGICE Mk3? I vaguely remember this being asked before but can't seem to find the thread. The HELP agent wasn't of any help. I looked around in the...
Saturday, 12 January 2013 - 03:04
ISR vector not populated [self solved]
!!!!! I put the exclamations here!!!! EDIT Current/Latest AS6 used I have spent a couple of hours trying to get some interrupts to fire, everything SEEMS to be set up correctly,...
Saturday, 29 December 2012 - 03:53
AS6 debug annoyances.
Just like death one puts off using AS6, but enevitably, just like death, one ends up dealing with it, unless death comes first in wich case all is well. :mrgreen: So "Build and...
Saturday, 22 December 2012 - 21:28
Xmega128A1 ADC
I remember reading something about the original ADC having some "issues" but I don't know if this is affecting my readings. Trying to read the pot on the Xplain board on portB bit...
Wednesday, 19 December 2012 - 09:20
TCC0 CTC mode??
I'm trying to replicate the "simple" CTC mode for timer0, but NOTHING is simple with the Xmega. :evil: The timer is running, the IVEC_TCC0_CCA_vect ISR fires but the overall time...
Monday, 10 December 2012 - 05:31
How many Xmega timers?
According to the ATxmega128A1 datasheet we are supposed to have "Eight 16-bit Timer/Counters" however I can only see definitons for TCC0 and TCC1 in the ATxmega128A1def.inc. I can...
Sunday, 9 December 2012 - 08:12
Xmega PLL multiplier [solved]
I'm trying to run a chip at 4MHz (doesn't have to but I just want to for now). It seems that the smallest mutiplier is 4 (8MHz), if I use 2 then the PLL is never ready and the...
Friday, 7 December 2012 - 05:28

Pages