Work of the Devil AVRISP MKII

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Not really sure where to post this one, but as it was a result of upgrading to AS5.1beta I guess this is as good a place as any as the latest firmware update came with it.

I have an AVRISP MKII that everytime that Atmel releases a firmware update I cringe, as it usually takes a shitload (technical term) of attempt to get the firmware update applied (anywhere up to 50 plus). Once upgraded it always functions without any issues.

Well today my Work of the Devil programmer simply refused the latest update, even after around 200-300 attempts. I was getting sick of it so I even wrote a batch file to execute avrfwupgrade in a loop. Still no joy.

I had tried the jumper on pins 1&3 and that also made no difference. I did however notice once pulling it appart that the atmega128 on it was just a little warm.

In desperation I thought what the .... and stuck it in the freezer for 10 minutes. After that guess what, the little bugger programmed correctly first time.

I guess the moral to my little story is that sometimes hell does need to freeze over.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hmm, some marginal design things happening, eh?

Do you do your work in Hades where electronics need a trip to the freezer?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:
Do you do your work in Hades
No he is in Canberra, the next stop is hades. :?

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

John,

So judging from your location that would make the next stop melbourne?