WinXP Problems

Go To Last Post
5 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Well, I tested WinXP with atmel yesterday, it didn´t turn out well...
Here´s what I used:
Cel 366, 196mb (Computer)
SDK200 (Programmer)
Atmel AVR ISP (Software)
AVR1200 (Chip)
WinXP build 2486 (OS)

Somtimes the program can´t find any dongle (problem disapear if I restart the program)
When I make a 'Program device' and then a 'Verify device', the verification fails, a lot of bytes wrong.

My guess would be that the problem lies in 'Atmel AVR ISP'.
Does anybody know of a better ISP programmer?
I have tried PonyProg, didn´t like it, I have tried Jespers yaap, didn´t work.

I hope Atmel will upgrade their old Win3.x programs, both AVR ISP and WAVRasm.

Does anybody else have WinXP/Atmel experience? Post them here!

/Anders Runeson, Sweden

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

WinXP (build 2462)
STK500
STUDIO 3.50

Assembly and programs OK

and ICE200, also OK

Steinar

admin's test signature
 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am afraid Atmel will not upgrade the ISP program to support any reasonable operating systems. Kanda had ISP 2.7b (IIRC), which was supposed to support Windows NT, but I have had rather bad experiences with it on both NT and W2k. The older programmer works sometimes with W2k but not always.

However, the program is made by Kanda, and Kanda has a new version available. The new version is able to use both Win9x and NT family OSes, probably XP (which belongs to the NT family) as well. Unfortunately, the new version is far away from being free, it costs some $125...

My solution was to use a STK500 as a programmer... The only bad thing is that STK500 serial protocol does not seem to be documented, so there are no Linux programmers available. The AVR Studio works fine with W2k.

(A small request to Atmel: Please, release the protocol, that should not affect your business any way.)

- Ville

admin's test signature
 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi Atmel ....

Yes please open the protocol as Ville Voipio sayes. I i have serious problems with bulk programming Mega163 (10 - 500 at a time) since it is only well supported under STK500.

Thanks

Niels Liisberg

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have had similar AVR ISP problems, but I thought they were related to processor speed rather than the operating system. My NT desktop machine is an 800MHz Pentium III. I have a lot of trouble with that. My laptop is a 100 MHz 486 running Windows 98 and AVR ISP works fine.