Why is AS5 so slooooooow!

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am not the fastest typist in the world, but sometimes AS5 struggles to keep up with my two-finger hunt and peck efforts.
In fact, if my wife tried to use AS5, she could probably type the entire works of Shakespeare before AS5 had even got to the "What! wherein Talbot overcame? is't so?" in Henry VI.
Is there some "feature" I can disable to speed things up a bit, or does Visual Studio rent out processing time on my computer to underprivileged nations without my knowledge?

Four legs good, two legs bad, three legs stable.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Two things have been suggested previously:

1) by default AS5 uses graphic drawing rather than text output APIs for the UI. This could be slow. Somewhere there's an option to switch it back to work like a "normal" Windows program

2) VA Assist X is turned on by default. It's the thing that does auto-completion but to do so it's parsing through .h files as you type. Try turning it off and see what transpires.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Visual Studio 2010 uses WPF and tries to use GPU acceleration when possible. But there may be slowdowns in dependency of your graphics card and display driver.

In Tools->Options->General you find "Visual Experience". Try different settings, and see if that speed things up.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks for the replies, although I'm pretty sure it's number 2 in Cliff's reply. I will try turning off VassistX, most of the time it's a major pain in the arse anyway, as the suggestions obscure what you're trying to do. Having said that, once in a while it's very handy, when I forget what something is called, or what the arguments are to a function. Shame there's not an "on-demand" option.

Thanks anyway for the replies.

John

Four legs good, two legs bad, three legs stable.