Version 1.15 firmware for LUFA based AVRISP MKII

Go To Last Post
3 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Atmel Studio 6.1 give the error: AVRISP mkII firmware must be updated before continuing.

I have version 1.14 on the tool.

Where do I find version 1.15 for the LUFA based AVRISP mkII?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I don't know, but you could try to change in Config/AppConfig.h or Lib/V2ProtocolParams.h to

#define FIRMWARE_VERSION_MINOR   0x15

and see if it works.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yes, that should be all that is needed for AS6.1 compatibility. The protocol is the same, it was just some bug fixes in the (original) tool's firmware that doesn't affect mine other than the increased version number requirement.

- Dean :twisted:

Make Atmel Studio better with my free extensions. Open source and feedback welcome!