verification error; content mismatch

Go To Last Post
5 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello,

Its a strange problem that I am facing till afternoon and it was doing well before that (I mean in the morning)

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.09s

avrdude: Device signature = 0x1e9403
avrdude: NOTE: FLASH memory has been specified, an erase cycle will be performed
         To disable this feature, specify the -D option.
avrdude: erasing chip
avrdude: reading input file "ioport.srec"
avrdude: input file ioport.srec auto detected as Motorola S-Record
avrdude: writing flash (1784 bytes):

Writing | ################################################## | 100% 50.26s

avrdude: 1784 bytes of flash written
avrdude: verifying flash memory against ioport.srec:
avrdude: load data flash data from input file ioport.srec:
avrdude: input file ioport.srec auto detected as Motorola S-Record
avrdude: input file ioport.srec contains 1784 bytes
avrdude: reading on-chip flash data:

Reading |                                                    | 0% 0.00savrdude:stk500_2_ReceiveMessage(): timeout
avrdude: stk500_2_ReceiveMessage(): timeout
Reading | #######                                            | 14% 12.08savrdude: stk500_2_ReceiveMessage(): timeout
avrdude: stk500_2_ReceiveMessage(): timeout
Reading | ##############                                     | 28% 24.17savrdude: stk500_2_ReceiveMessage(): timeout
avrdude: stk500_2_ReceiveMessage(): timeout
Reading | ######################                             | 43% 36.25savrdude: stk500_2_ReceiveMessage(): timeout
avrdude: stk500_2_ReceiveMessage(): timeout
Reading | #############################                      | 57% 48.33savrdude: stk500_2_ReceiveMessage(): timeout
avrdude: stk500_2_ReceiveMessage(): timeout
Reading | ####################################               | 71% 60.41savrdude: stk500_2_ReceiveMessage(): timeout
avrdude: stk500_2_ReceiveMessage(): timeout
Reading | ###########################################        | 86% 72.49savrdude: stk500_2_ReceiveMessage(): timeout
avrdude: stk500_2_ReceiveMessage(): timeout
Reading | ################################################## | 100% 84.35s

avrdude: verifying ...
avrdude: verification error, first mismatch at byte 0x00d2
         0x88 != 0x01
avrdude: verification error; content mis

match

Any suggestions. Please let me know.

Thanks,
Anmol Kumar

Last Edited: Thu. Jun 25, 2015 - 08:04 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Strange Now mismatch is at different address, have a look

avrdude: verifying ...
avrdude: verification error, first mismatch at byte 0x00cb
         0xe0 != 0x04
avrdude: verification error; content mismatch

avrdude: safemode: lfuse reads as E1
avrdude: safemode: hfuse reads as 99
avrdude: safemode: Fuses OK
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Well at first sight all those timout errors would seem to suggest that your ISP link is only just on the borderline of working - I think it's -i you use to delay the ISP bit-clock - might be worth a try.

But if this electronics worked before and is now not working and you haven't changed the AVR fuses in the meantime then it suggests it's simply an electrical fault.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

clawson wrote:

But if this electronics worked before and is now not working and you haven't changed the AVR fuses in the meantime then it suggests it's simply an electrical fault.

That was due to some fuse settings changed inadvertently .

Now Its working fine. Thanks for quick reply of yours.

bye bye

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I had same problem. Try lowering the bitrate parameter. For me works aver dude -c dragon_isp -p m32 -B 5.

Topic locked