Variable color in AS7

Go To Last Post
8 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Sometimes the color of variables in my projects are black instead of the default Navy.  Sometimes if I scroll up and then back down they will change to Navy.  Sometimes not.  It is most annoying.  If I close the project and reopen it the variables are Navy, like they should be.  Is there some other way to make this happen?  Has anyone else seen this?  Could it be because I have an old graphics card that I was warned about when installing AS7, or is this just an AS7 bug?  I haven't tried opening Visual Assist Options where the colors are defined, and clicking on OK.  Maybe that will work.  This is a small intermittent issue, and should't make me want to go back to AS6.2.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

It may well be a video driver/card issue. Have never seen any intermittency.

 

Jim

Jim Wagner Oregon Research Electronics, Consulting Div. Tangent, OR, USA http://www.orelectronics.net

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

There's an option in AS7 (and VS2015) to switch off advanced graphics usage. Try that.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Cliff, you are such a tease.  I cant find it.  I can turn off Visual Assist, but I cant find advanced graphics usage.  Where is it?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Tools->Options (think it's called hardware accelerated sumethin')

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I found Tools>Options>Environment>General and a checkbox for "Use hardware graphics acceleration if available" if I uncheck "Automatically adjust visual experience based on client performance"  I will try that the next time it happens to me.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yup that's the one I was thinking of. 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

OK, I will try it next time I get weird graphics.