USBASP and AVRDude

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Today I got an USBASP 2.0 interface, and wanted to use it with AVRDude, installed together with GCBasic and updated (Presently I use Kanda's ISP2 with W7 x64 but will PERHAPS migrate to FreeBSD in a near future). After installing the drivers I tested it from GCBasic and "standalone" with AVRDudess. No context was satisfying. I adjusted first the parameters inside AVRDudess :
Programmer : USBASP
System clock automatically set to 1.5 MHz
Verify and Erase activated.
I removed the « voltage » jumper, I think otherwise the USBASP powers the application board (in my case ST200).

I think the remaining parameters are automatically generated by GCBasic (or not ? )
There was an error message :
avrdude.exe: ser_open(): can't open device "\\.\COM4": Le fichier spécifié est introuvable. ( = File cannot be found)

I added the missing informations in AVRDudess (especially processor and the name of the Hex file) and used it directly, "something" happened but at the end I got a verify error at Byte 0000. The most important message in my eyes was :
avrdude.exe: warning: cannot set sck period. please check for usbasp firmware update.
Connecting again ISP2 I saw that flash memory had been erased but not programmed.
So, what can I do ? I tested several values for clock without success.

 

Thanks for any answer ...

 

Last Edited: Fri. Oct 23, 2020 - 05:56 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

avrdudess is trying to find the usbasp on com4

 

change the port  to usb.

do not enter a baudrate setting

 

try lowering the system clock (try 187.5 KHz)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks. Problem solved, even at 1.5 MHz ... And I thought that selecting "verify" would include "programming", it doesn't ... I had to select "Write", not select "Disable verify" and select "Erase" ... Unfortunately there is no "Help" in AVRDudess ! On the other side, there is stille the message :

avrdude.exe: warning: cannot set sck period. please check for usbasp firmware update.

???

Last Edited: Sun. Oct 25, 2020 - 06:27 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

That message can be safely ignored, the Chinese firmware on usbasp takes care of that function.

Do not update the firmware, all is good

 

jim

 

 

(Possum Lodge oath) Quando omni flunkus, moritati.

"I thought growing old would take longer"