Upgrade the Avr-Libc 1.6 to AVR-Libc 2.0

Go To Last Post
2 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Device  : ATMEGA8

IDE: avrStudio 4

avr-Libc:1.6 with WINavr20100110

My Question  is : How can i upgrade the Libc 1.6 to 2.0 using avrStudio4 and I don't want to install avrStudio7

 

 

Please i am seeking for you help  to give steps in simple way because  i am beginner in avr programming.

 

Thanks in advance 

This topic has a solution.
Last Edited: Tue. Mar 14, 2017 - 03:51 PM
This reply has been marked as the solution. 
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Versions of LibC match versions of avr-gcc. So the answer is "you cannot do this". Things like EEPROM support changed radically between 1.6 and 2.0

 

If you just want a command line avr-gcc for Windows why don't you simply get:

 

http://www.atmel.com/tools/atmel...

 

Right now I think that will give you an avr-gcc v4.9.2 and Libc 2.0

 

However Atmel just released a new AS7 and it has avr-gcc 5.4.0. If you wait a day or two that standalone avr-gcc for Windows will also update to 5.4.0 so it might be worth waiting for.