Upgrade 6.2 to 7.0.934

Go To Last Post
7 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I decided to try Studio 7, even though I don't need it.  I can't upgrade the project.

 

I can get two different error messages.  The first one looks like this:

 

 

 

If I try again, I get this:

 

 

 

 

 

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I should have mentioned, I tried this on Windows 10.  Changing Studio versions and changing Windows versions at the same time is pretty stupid, so I can just forget the whole thing, unless someone has a better idea.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am getting similar results on old projects using version 7.0.943.  What is also happening is adding existing files to new projects results in the errors below.  I am running windows 8.1 (completely new install) and fresh install of the latest Atmel Studio.

 

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

It's the upgrade from 6 to 7 that fails in my case.  So I have no project to build.  I've never had an upgrade fail before. 

 

I have a spare clean Win10 installation on my secondary computer.  I decided to try to install Studio 7.  The installation went well.  No problems.

 

Then I copied over a 6.2 project.  The upgrade to 7 fails miserably, with an error message that means nothing to me.

 

The first attempt results in "Value cannot be null.  Parameter name: url"   Huh?

 

Apparently it did make a copy of the .atsln file and added the file name suffix _6_2 to this new .atsln.

 

The second attempt to upgrade says it is denied access to that copy.   Huh?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Are you by chance running SkyDrive?  I have narrowed some of my issues to permissions on SkyDrive.  I'm still not up and running fully, but can at least build an old project.  Is seems other people are experiencing issues as well with other software and SkyDrive.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Not SkyDrive, but I did find the problem.  The .atsln file was read only.  After I fixed that, the project upgraded and built without error.  Hallelujah!

 

As soon as I can figure out how to run the debugger, I should be in business. 

 

The Start Debugging entry is grayed out.

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

Getting the debugger to work was easy.  I just killed Studio and restarted it.  Voila! debugger works.  The build runs fine too.  Success!  I now pronounce Windows 10 to be Studio 7 ready.  At least for Studio 7.0.934. 

 

It seems the abortion that results when trying to upgrade to 7 with a read only .atsln file is a bug that ought to be fixed. 

 

My files get set to read only when I archive them with Source Safe.  I'm probably the only one that uses Source Safe, but if others get their files set to read only, this will be an obnoxious problem.

Last Edited: Sat. May 21, 2016 - 03:41 PM