Unable to Dump code in Controller using Atmel ICE Debugger

1 post / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello All,

 

I have custom PCB with ATSAME54P20A microcontroller chip. I am trying to dump the code using ATMEL ICE Debugger in to the controller but facing the issue. 

 

I got the error message as "Failed to launch program. Error: Could not activate interface but found DAP with ID 0x2ba01477." 

 

The Atmel ICE debugger is using SWD interface with default clock as 2 MHz. 

 

I have tried following methods discussed already in the forum over here but with no success:- 

 

https://community.atmel.com/foru...

 

Also, I am getting "Verify Failed error" when clicking the verify button under "Memories" tab  under Device Programming option in Atmel Studio 7 Tools option.

 

The error is exactly as mentioned in the below link:- 

 

https://community.atmel.com/foru...

 

 

 

 

Also, tried programming fuses under fuses menu but it is showing error when we click verify button as "One or more registers differs". 

 

Do I need to change any fuses value or is it OK not to change it, that's the main question ?? 

 

Please, help me with this issue. 

 

Thanks in advance.