Trouble programming ATTiny85 with AVRISP mkII

Go To Last Post
9 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I'm trying to program an ATTiny85 via AVRISP and AVR Studio 4.19 and getting an ISP mode error in the process. I want to use the internal 8 MHz oscillator, which should be the default, but the fuse appears to be set to an external clock (see attached screenshots). When I try to change it to internal and hit Program, I get the error. I have a 1K pullup resistor on RESET, and have the programming frequency set to 1 MHz. Any thoughts about what I should check or do differently? Thanks.

Sorry if this should be in the AVR Studio forum. Seemed equally at home here, so I flipped a coin. ;-)

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Can you even read the device signature? It does not look like you have.

"I may make you feel but I can't make you think" - Jethro Tull - Thick As A Brick

"void transmigratus(void) {transmigratus();} // recursio infinitus" - larryvc

"It's much more practical to rely on the processing powers of the real debugger, i.e. the one between the keyboard and chair." - JW wek3

"When you arise in the morning think of what a privilege it is to be alive: to breathe, to think, to enjoy, to love." -  Marcus Aurelius

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

larryvc wrote:
Can you even read the device signature? It does not look like you have.

No. The ISP says it's unable.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

If you can't read the device signature then you certainly cannot have read the fuses. The pictures you posted above are valid only in the fact that you have connected with the AVRISP mkII. You have not connected with the chip. Try setting the ISP frequency below 250kHz in case the chip is running at 1MHz. Also double check your connections. Try to read the device signature again with the slower ISP frequency.

"I may make you feel but I can't make you think" - Jethro Tull - Thick As A Brick

"void transmigratus(void) {transmigratus();} // recursio infinitus" - larryvc

"It's much more practical to rely on the processing powers of the real debugger, i.e. the one between the keyboard and chair." - JW wek3

"When you arise in the morning think of what a privilege it is to be alive: to breathe, to think, to enjoy, to love." -  Marcus Aurelius

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

1K seems like a low value to use as a pullup. Perhaps your programmer struggles with the current to pull the reset line low. Are you able to replace it with a 10K instead?

Ross McKenzie ValuSoft Melbourne Australia

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Props to valusoft and larryvc. I replaced the pullup with 5.6K (the datasheet says nothing stronger than 4.7K, so I was in violation there), and dropped the programming frequency to 250 KHz. Everything's fine now. Increasing the frequency above 250KHz replicates the problem, so that was definitely part of the issue.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Does the Tiny85 RAW come with a div/8 fuse set as default ? If so , then the iSP frequency has to be =<250KHz....

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yup, it's set by default. Resetting it allows programming up to 2 MHz. Thanks!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

This all indicate that you missed to read the RTFM register before programming :lol:

Warning: Grumpy Old Chuff. Reading this post may severely damage your mental health.