studio2.1 and toolchain 2.1.4 give old code a lot of warning

Go To Last Post
7 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

hi,

I just uninstalled my old studio2.0.2 and toolchain 2.0.3, and installed the new ones, then i selected the same old workplace for my old C codes, and then compiler give me a lot of warning and error, like a lot of #include becomes unresolved with questionmask beside. Then I uninstalled the new ones and reinstalled the old ones again, and then my old codes compiles without problem. But i don't understand what happened? I haven't change anything with my old framework1.3.0.

Anyone have similar experience?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

i had the same problem but i just changed the code in my sw that gave the errors. i also removed the old sw framework from my project and included the new sw framework. no problems with compiling anymore.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

There have been many defines that have been changed, that is why your code has been breaking. Some of these are due to bug fixes, some are just because the names have been changed, but the old ones were removed instead of leaving them in and going through a deprecation period. We're working on something that should help the situation, look for it sometime in the next couple of weeks. In the meantime, if you have existing applications and you don't need to upgrade, then stick with 2.0.3.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

ok, then i will wait.

thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

i also tried with the new software framework but still my code got a lot of Unresolved inclusions, like for example: . My old codes always use my own makefile and configuration file, so i'm wondering if there is a makefile setting change from the new studio32 2.1 and toolchain V2.1.4, so if so, how can i keep up using my old makefile configrations?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

darthvader wrote:
i also tried with the new software framework but still my code got a lot of Unresolved inclusions, like for example: . My old codes always use my own makefile and configuration file, so i'm wondering if there is a makefile setting change from the new studio32 2.1 and toolchain V2.1.4, so if so, how can i keep up using my old makefile configrations?

The advice i got in this thread
https://www.avrfreaks.net/index.p...

got me rid of the problem

/Nicholas

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

i selected this "AVR32/GNU C per project" in my AVR32Studio, but the erros are still the same.