Studio 6.2 Memory View with bootloader using Xmega32E5

1 post / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Writing a bootloader - using snippets from various sources and having to keep it light as I have to have can bus support within it.

I thought I was making progress - after a LONG time when I wasn't seeing ay change in the memory view for the prog App section, I decided to change the program, simply fill a buffer with data, erase page 0 then write page 0.

The first few times I tried this new approach it worked, I halted the code and saw the data written into the flash.

 

After a short break, I decided to return to the code - but .. now the same code doesn't work. Well the memory view doesn't show the data being written, and Ive tried a fair number of times.

 

I see an errata about 6.2  that states the eemem is corrupted if it is edited in the memory view, well I'm not using the eemem so that doesn't apply, but what I DO see is that manually writing to the Flash application area using the memory view then upsets studio 6.2 somewhat,  ( code doesn't restart from a break) normally needing a tool restart.

 

I now don't know if Im chasing a bug in the code or a bug using the Xmega32E5, or studio 6.2 or a combination.

This is becoming hard work - any clues?