Studio 6.1 programming tool suggestions

Go To Last Post
3 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

If you read the device signature with the wrong device selected a message pops up saying the device is a ATMegaXXX. when you close that you have to manually change the device selection and hit the apply button. I suggest adding an option to the error message box that says "Would you like to select this device and apply?" (i frequently forget to hit that apply button). Also I would like the mouse wheel to scroll the dropdown device list. There is also a bug that manifests if you select ATMega168P and the device is an ATMega168A. the error message identifies the part as an ATA66XX (I can't remember the last 2 digits)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

ATMega168A. the error message identifies the part as an ATA66XX

Thats because they have the same ID, which is as crazy as it seems. Studio then uses the first and best ID match.

Quote:

I suggest adding an option to the error message box that says "Would you like to select this device and apply?"

Put a enhancement request into bugzilla, so that I can track it. Sounds like a good idea though as far as I can see...

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Well, actually it's physically the same die. The ATA6613C is System in Package containing the ATmega168 and the ATA6624C. Maybe it would be nicer if ATA6612C/ATA6614Q would point to ATA6613C and ATmega168XX to corresponding megas. Not sure though if that is easily doable.