Studio 6 + Atmel ICE + !%^£"$"%^$%^"

Go To Last Post
15 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Can I just say I love Studio 6?

 

(that is all).

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Overall I have no major issue with it after the painkillers take effect. I am using mt Atmel ICE and AS6 right now

 

What's your problem?

 

JIm

I would rather attempt something great and fail, than attempt nothing and succeed - Fortune Cookie

 

"The critical shortage here is not stuff, but time." - Johan Ekdahl

 

"If you want a career with a known path - become an undertaker. Dead people don't sue!" - Kartman

"Why is there a "Highway to Hell" and only a "Stairway to Heaven"? A prediction of the expected traffic load?"  - Lee "theusch"

 

Speak sweetly. It makes your words easier to digest when at a later date you have to eat them ;-)  - Source Unknown

Please Read: Code-of-Conduct

Atmel Studio6.2/AS7, DipTrace, Quartus, MPLAB user

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

VirtualBox. 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Installed the VBox Extension Pack? Need that to get all the endpoints through...

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have. 

 

ICE is stuck in upgrade mode. I run atfw. It says "waiting for enumeration". Then it appears to start the update and does the [=====- ] thing. It gets to about 75% every time then craps out with "generic error" (not near PC now but it was something like that). I can repeat this 100 times. It's the same every time :-(

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Maybe you need a real windows PC surprise

 

Jim

I would rather attempt something great and fail, than attempt nothing and succeed - Fortune Cookie

 

"The critical shortage here is not stuff, but time." - Johan Ekdahl

 

"If you want a career with a known path - become an undertaker. Dead people don't sue!" - Kartman

"Why is there a "Highway to Hell" and only a "Stairway to Heaven"? A prediction of the expected traffic load?"  - Lee "theusch"

 

Speak sweetly. It makes your words easier to digest when at a later date you have to eat them ;-)  - Source Unknown

Please Read: Code-of-Conduct

Atmel Studio6.2/AS7, DipTrace, Quartus, MPLAB user

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Or better still a Linux Studio! surprise surprise

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

LinuxStudio could be a reason to switch from Microchip to Atmel wink

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Maybe you need a real windows PC

I've had a few of those in my time. Even ones where I ran Windows as the ohst OS then Linux in a VirtualBox but I find that doing it the other way round is the best solution of all. I also use other applications in a VirtualBox running Windows that happily speak to their USB 2.0 devices (I have the VB extension pack installed) but Atmel really seem to have some problem getting their USB communication "right" so that it just works seamlessly.

 

Yes I guess I will have to run a PC or laptop with native Windows if I want to use this Atmel-ICE - or I could just leave it in a box and stick with my trusty old (USB 1.1) JTAGICEmkII

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi
Please look at the thread
http://www.avrfreaks.net/forum/atmel-ice-and-linux
The endpoint problem is solved using filter, in last answer there is a screenshot with 3 filters
The reason is this: studio changes driver for upgrade, and vbox does not allow the new usb device to get in. You need to go to vbox launchpad and add usb filter, it will be displayed automatically in usb->add filter dialog. Then vbox will allow it without asking.
Then, restart ice and try to build again in studio
Works like a charm :)
Forget native windoze :D
I vote for linux studio, too!

Greetings, Tom

Last Edited: Wed. Apr 15, 2015 - 03:27 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

No I already have such a filter set up (in fact if you look in the tutorial forum you'll see I wrote an article about the need to set up a vbox USB filter for this). In my case the device is already stuck in "bootloader" mode and is connected to vbox as such. It even starts the upgrade but fails at 75% every time. 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Linux Studio would be appreciated.    May stick with Atmel a bit longer then but they should not wait too long.

 

Wrt to your problem, when the ICE goes into bootloader mode VB disconnects it; it is a new device; in my case I had to attach the "new" bootloader device again to Windoze.

 

AS 4.18 works a treat in VB...  Maybe another reason to encourage Atmel to create the new CPU files.   Cannot be much more than running a few scripts for them....

Last Edited: Sat. Apr 18, 2015 - 03:09 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

When it goes to 75% it means the device is visible. When it breaks, it may be everything. Timeout, whatever.
I wish I were smart enought to find clawson tutorial - I'd save few hours :)

Greetings, Tom

Last Edited: Sat. Apr 18, 2015 - 03:46 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

sq5rix wrote:
I wish I were smart enought to find clawson tutorial - I'd save few hours :)
You are smart; maybe it's an operator headroom problem wink

Search found 5 items

https://www.avrfreaks.net/search/site/%5BTUT%5D?f[0]=im_taxonomy_forums%3A636&f[1]=is_uid%3A28397

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

And amongst those results it's this one I meant... 

 

https://www.avrfreaks.net/forum/t...