Studio 4.10 install

Go To Last Post
9 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

We are advised to uninstall all previous version of Studio before installing v4.10. Does this include v3.56 or just v4.xx versions? Unfortunately I have to revert back to the older version for debugging as there is an unresolved problem with Studio 4.xx and ICE200 and have been advised to use the older version until (IF EVER :cry: ) a solution is found.
i.e can I still keep the older version of Studio without unistalling it and have have the newer version as before?

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The advice on uninstalling is only for version 4.x. Version 3.x can be kept on the system.
The reason for the advice is that we are moving the installation from Windows Installer to InstallShield. Uninstalling the previous version makes sure that Studio 4 is removed from the Installer database.

Lars Kvenild
AVR Studio dev team
Atmel Norway

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Trym wrote:

The reason for the advice is that we are moving the installation from Windows Installer to InstallShield.

I'm curious, is there some overwhelming reason for you to switch installers?

Thanks
Eric

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Up till version 4.09 we used Visual Studio .NET as a tool for writing the installation. This is an excellent tool, but we wanted to do stuff that is easier done with InstallShield’s scripting language. Like adding custom dialogs, managing the USB installation and more. InstallShield is also an old friend we have used in other settings. When switching we also decided to get the most out of InstallShield by using their methods for installation and not their implementation of Windows Installer.

lars k

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Good points. Thanks for answering!

Eric

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I've installed 4.10 b 356 twice on this machine, and Help/About still reports 4.10 b 345.

I've tried deleting everything (except my projects). How do I get proper install of 4.10 b 356?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

mneary wrote:
I've installed 4.10 b 356 twice on this machine, and Help/About still reports 4.10 b 345.

I've tried deleting everything (except my projects). How do I get proper install of 4.10 b 356?


When I select Help, About AVR Studio then click on the Version button I get:
Quote:
AVR Studio 4.10.356
GUI Version 4, 10,0,345

The debugger does work with WINAVR .elf output.

Don

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I apparently wasn't deleting enough. This time, it worked and it reports 356. Thanks!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Up until 4.09 the build number of Studio was the same as the version number of the file AvrStudio.exe. From 4.10 this is changed so the build number reported is the build number of the InstallShield installation. This is why the GUI version is listed in the Version dialog. This enables us to distribute a new build without having to upgrade the main executable.

lars k
atmel norway