src/asf/common/services/clock/xmega/sysclk.o] Error 1

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

If this problem has already been addressed in another thread, my apologies.

I have been using AVR Studio 5 for a couple of weeks without problem. (Windows 7 operating system) Then suddenly things start going wrong. The first problem was that my ICE3 was not found. Reinstalling Studio 5 solved that, but it only fails again after a short while. I have since learned the Jungo USB driver is at fault.

However, now I can no longer compile anything. Even the example files fail. I get the errors below.

[src/asf/common/services/clock/xmega/sysclk.o] Error 1

Failed to remove the Framework.config file from the project

I have a brand new install of Windows 7 on another drive. That appears to work, although Studio 5 has already been uninstalled and then re-installed to solve both the USB and above problem. That version is currently working.

So for my current operating system, I did do a windows update 2 days ago to try and solve these issues. That did not help. Anybody able to shed any light on this?

Thanx
Brian

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Ok ... uninstalled C++ Builder. Now Studio 5 can compile again. For what ever reason, it seems that when compiling in Studio 5, the make file used is not the correct one, but somehow sees the C++ Builder version.

when using plain old WINAVR, I would need to have a copy of make.exe in the actual directory my source files existed, also due to C++ Builder issue. Not sure why this is.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Nice programs add to the end of PATH where conflicts are not likely to break anything else. Adding to the start gives priority to the new install. Look at >set PATH for the order; you can copy and paste that into a text window and change the order around, then paste it back into a command window as >set PATH=whatever and try it out. That change will only apply to the current window; to make it permanent change it in Computer->System Properties->Advanced System Settings->Advanced->Environment Variables.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

well ... it seems problem remains. So not 'path' related.
Got to re-install Studio 5 at least 1 or twice a day

This is a real pain!!!!