Source file not compiled

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,
i started my project in Atxmega128d3 with Atmel studio 6 for small application. But later i need more flash area so i changed my device to Atxmega256d3.
Everything is ok except two files keypad and adc interface routine files. These routines operation was successful with atxmega128d3. After switched to Atxmega256d3 i made a change in that files then i compiled and flashed well. But operation of the controller is not code written way. Again i changed my device as atxmega128d3 after that compilation and flashing is ok as well as operation of controller is expected way. what is a technical things behind this problem.

To get a correct output i did some work but i didn't get, the works are
1. Changing device then leaning solution and build it,
2. Changing device then Cleaning solution and rebuild it,
3. Changing file names,
4. Changing routines names,

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Post the complete build output and name the files you think should be compiled but you think are not being.

Could it be there functions are being garbage collected perhaps?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

clawson wrote:
Post the complete build output and name the files you think should be compiled but you think are not being.

Could it be there functions are being garbage collected perhaps?

I attached text file of built output. Name changed two files are keypad.c to keyTimer.c and adcmange.c to BatManage.c

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Well keytimer.c is there but the other two are not. Do you see them listed in the Solution Explorer view of the source files? If they are there then right click to see their properties - perhaps they are set to "exclude from compilation"?