[SOLVED] Unabe to enter programming mode on ATMEL Studio

1 post / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello guys, this is my first post here in this forum, and currently I’m experiencing an issue while trying to burn the bootloader on the ATmega2560 chip on the PCB board that I have designed.

 

So… I’ll try to do a brief explanation about what is happening. After trying to burn the bootloader on ATmega2560 using the USBasp programmer I decided to follow a tutorial that I have found on the internet called “How to flash the Arduino bootloader without a programmer” (Here is the link: How to Flash Arduino Bootloader without a Programmer – Welldone Blog (fedevel.com) ) And I know this tutorial is for an Arduino UNO but my board works similar to an Arduino Mega so If I’m not wrong this tutorial works for the Arduino MEGA as well).

 

Basically in this tutorial I have transformed the ATmega16U2 chip on my board into a AVRISP MKII clone and then I had to connect the ATmega16U2-ICSP connectors such as MISO, MOSI, SCK and PB4 to the ATmega2560-ICSP using some jumper wires. As you can see there’s an image below showing the connections I should do, and the other image shows my actual board already with the jumpers.

 

 

I was doing everything correctly until I got to spep 7 that says : Go to: “Device signature” and click on “Read” button. You should see the correct “Device signature” 

 

When I click on the button “Read” on the Atmel Studio 6.2 it shows me this error:

 

 

After that I tried to find some solutions on the internet, but after trying so many things I had no success. So for that reason I’m here, I don’t why I’m seeing this error and don't know what could be the solution. Before publishing I wanna to make a list of the things that I have already tried and give important informations that could help finding the solution.

 

  1. Things that I have already tried:
  • Double checked the wire jumpers connection.

  • Changed the wire jumpers 3 times

  • Verified connection of MISO, MOSI, SCK and RESET between ATmega2560 and ATmega16U2 with a multimeter.

  • Verified the fuse settings of ATmega2560 on Extreme Burner with USBasp and this was the result!

 

  1. Important things
  • Some programs that I have used can recognize the ATmega2560 by USBasp such as Extreme burner and AVRDUDESS!

  • I'm using brand new microcontrolers that have never been used before!

  • I'm using ATMEL Studio version 6.2 on my computer.

  • I Think that Extreme Burner for some reason can read the device signature of my ATmega2560 by USBasp as shown in the image below!

 

  • I have no experience with ATMEL Studio software and this is my first time trying to burn the bootloader into a microcontroller!

 

So, With all this information provided I hope someone here helps me, honestly I think that finding the problem is not something very hard, but as a have no experience using Atmel Studio software I need help, my theory is that is something wrong happening with my Atmel Studio 6.2 software, since I have revised my board many time, So I appreciate the answers of everyone who tries to help me. Many Thanks!

Last Edited: Sun. Feb 7, 2021 - 03:22 AM