Solved: Arduino Leonardo upload problem

Go To Last Post
13 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

 

I'm programming Arduino Leonardo (ATMEL 32u4) board using Atmel studio 7. But when I'm going to upload my code, it gives me following

How to solve this problem.

Here I'm attaching the screenshot of my error message.

 ( .avrdude.exe: butterfly_recv(): programmer is not responding).

 

Attachment(s): 

vkm

Last Edited: Wed. Apr 3, 2019 - 09:33 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

What is your avrdude command line?

 

Look at how the Arduino IDE sends the avrdude command(s)

 

David.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I set the following commands int  AtmelStudio -> external tools menu.

 

avrdude command line -> C:\Arduino\hardware\tools\avr/bin/avrdude.exe 

Argument ->  -C"C:\Arduino\hardware\tools\avr/etc/avrdude.conf" -v -patmega32u4 -cavr109 -PCOM39 -b115200 -D -Uflash:w:"$(ProjectDir)Debug\$(TargetName).hex":i 

vkm

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thankx. I found the answer (https://nicholaskell.wordpress.c...)

vkm

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

kaushv wrote:
Thankx. I found the answer
Would the answer be that you changed -b115200 to -b57600 by any chance?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

 I'm programming Timer5 interrupt to  my Arduino Mega board using Atmel studio 7.  But ISR commands are not working with the IDE. (Same code runs perfectly on Arduino IDE). Can some one help me to solve this problem. I attach my code with this post.

 ISR(TIMER5_OVF_vect)
 {
	 led_ON();
 }
 ISR(TIMER5_CAPT_vect)
 {
	 led_ON();
	 
 }

 

vkm

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

As you have now posted this question in a new thread:

 

https://www.avrfreaks.net/forum/...

 

I will lock this.

Last Edited: Wed. Apr 3, 2019 - 09:33 AM
Topic locked