Setting the JTAG port frequency in 4.05

Go To Last Post
2 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

In 3.x (and IIRC in earlier versions of 4.x), the JTAG port frequency could be entered either in full - e.g. 2000000 - or in abbreviated form - e.g. 2 MHz. After installing 4.05, I noticed all JTAG operations were taking *far* longer than usual to complete, and looking at the JTAG ICE Properties dialog shows why.

If you enter the port frequency in the abbreviated form, the 4.05 dialog ignores the frequency modifier part (the MHz bit), and just takes the numerical part as being the actual frequency. Thus, if you enter 2 MHz, exit the dialog and then open it again, you'll see your frequency setting now reads 2... Just something to watch out for in case, like me, you've installed 4.05 and are now wondering why your JTAG ICE is running like treacle on a cold day :-)

Regards
Chris

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Follow-up time...

It seems that the JTAG ICE Properties dialog in 4.05 is even less well-behaved than it first appeared, in that it is all too eager to forget settings you've just made, or to incorrectly read settings out of your .aps project file.

As noted above, there's a problem setting the port frequency. However, even if you enter the frequency longhand (e.g. 2000000), the next time you load Studio the frequency will be set wrongly - 2000000 becomes 2. Looking in the .aps file shows an entry 2e+006, which means the setting is being saved correctly, it just isn't being read correctly. However, once set again within the properties dialog, it remains correctly set for the remainder of the Studio session.

Next, the "Run Timers in Stopped Mode" setting. Whilst it appears to work OK, in that clearing the tickbox and exiting the dialog causes the timers to be halted during debugging, as soon as you re-enter the properties dialog you'll notice this setting has been ticked again. If you want those timers to remain off, remember to check this setting every time you go into the properties dialog!

Finally, the Advanced setting to decide when the reprogram the device isn't remembered from one Studio session to the next - it always return to "Always reprogram device when loading object file". Which, of course, means that every time you load an existing project ready to start a debugging session, you have to wait for the AVR to be reprogrammed. And with the problem of the JTAG port frequency being reset as well, this makes the overall Studio startup time a lot longer than it ought to be...

Regards
Chris